]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-kernel/linux/linux-ti-staging_3.8.bb
6e64fc5b00a2ab3554c2a44f58502f643ba1cf5a
[glsdk/meta-ti-glsdk.git] / recipes-kernel / linux / linux-ti-staging_3.8.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for TI devices"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5 KERNEL_IMAGETYPE = "uImage"
7 inherit kernel
9 require recipes-kernel/linux/linux-dtb.inc
10 require recipes-kernel/linux/setup-defconfig.inc
12 # Add a run-time dependency for the PM firmware to be installed
13 # on the target file system.
14 RDEPENDS_kernel-base_ti33x += "am33x-cm3"
16 # Default is to package all dts files for ti33x devices unless building
17 # for the specific beaglebone machine.
18 KERNEL_DEVICETREE_ti33x = "arch/arm/boot/dts/am335x-evm.dts arch/arm/boot/dts/am335x-evmsk.dts arch/arm/boot/dts/am335x-bone.dts"
19 KERNEL_DEVICETREE_beaglebone = "arch/arm/boot/dts/am335x-bone.dts"
20 KERNEL_DEVICETREE_omap5-evm = "arch/arm/boot/dts/omap5-sevm.dts arch/arm/boot/dts/omap5-uevm.dts"
22 COMPATIBLE_MACHINE = "ti33x|omap-a15"
24 S = "${WORKDIR}/git"
26 BRANCH = "ti-linux-3.8.y"
28 # This commit corresponds to ti2013.04.00 release tag
29 SRCREV = "23e7f725a6af4ca44660c06bc3569f6ce705d1d0"
30 PV = "3.8.8"
32 # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
33 MACHINE_KERNEL_PR_append = "c+gitr${SRCPV}"
35 SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
36            file://defconfig \
37           "