1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for TI devices"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5 KERNEL_IMAGETYPE = "uImage"
7 inherit kernel
8 require recipes-kernel/linux/linux-dtb.inc
10 # Stage the power management firmware before building the kernel
11 DEPENDS += "am33x-cm3"
13 KERNEL_DEVICETREE_am335x-evm = "arch/arm/boot/dts/am335x-evm.dts"
14 KERNEL_DEVICETREE_beaglebone = "arch/arm/boot/dts/am335x-bone.dts"
16 COMPATIBLE_MACHINE = "ti33x"
18 S = "${WORKDIR}/git"
20 BRANCH = "ti-linux-3.8.y"
22 SRCREV = "d26595a42220789b81a9d243e2fc0837c7776360"
23 PV = "3.8.2"
25 # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
26 MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
28 SRC_URI = "git://gitorious.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH}"
30 do_setup_defconfig() {
31 :
32 }
34 do_configure() {
35 oe_runmake omap2plus_defconfig
36 }
38 # Copy the am33x-cm3 firmware if it is available
39 do_compile_prepend() {
40 if [ -e "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" ]
41 then
42 cp "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" "${S}/firmware"
43 fi
44 }