]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-kernel/linux/linux-ti33x-psp_3.1.bb
linux-ti33x-psp 3.1: register all cape/daugherboard EEPROM permutation in the boardfi...
[glsdk/meta-ti-glsdk.git] / recipes-kernel / linux / linux-ti33x-psp_3.1.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for TI33x EVM from PSP, based on am335x-kernel"
3 LICENSE = "GPLv2"
4 KERNEL_IMAGETYPE = "uImage"
6 require multi-kernel.inc
8 S = "${WORKDIR}/git"
10 MULTI_CONFIG_BASE_SUFFIX = ""
12 BRANCH = "v3.1-meta-ti-r1r+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d"
13 SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d"
14 MACHINE_KERNEL_PR_append = "h+gitr${SRCREV}"
16 COMPATIBLE_MACHINE = "(ti33x)"
18 THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
19 CONFIGS_PSP = "${@base_set_filespath(["${THISDIR}/${PN}-${PV}/tipspkernel"], d)}:\
20 ${@base_set_filespath(["${THISDIR}/${PN}/tipspkernel"], d)}:\
21 ${@base_set_filespath(["${THISDIR}/files/tipspkernel"], d)}:"
22 FILESPATH =. "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "${CONFIGS_PSP}", "", d)}"
24 SRC_URI += "git://github.com/beagleboard/linux.git;branch=${BRANCH} \
25         file://defconfig"
27 PATCHES_OVER_PSP = " \
28         file://0001-f_rndis-HACK-around-undefined-variables.patch \
29         file://0001-ARM-omap-am335x-BeagleBone-version-detection-and-sup.patch \
30         file://0002-ARM-OMAP2-beaglebone-add-LED-support.patch \
31         file://0003-ARM-OMAP2-beaglebone-add-DVI-support-needs-cleanup.patch \
32         file://0004-da8xx-fb-add-DVI-support-for-beaglebone.patch \
33         file://0001-usb-musb_core-kill-all-global-and-static-variables.patch \
34         file://0002-arm-omap-am335x-correct-32KHz-clk-rate.patch \
35         file://0003-arm-omap-mcspi-correct-memory-range-when-requesting-.patch \
36         file://0004-arm-omap-mcspi-follow-proper-pm_runtime-enable-disab.patch \
37         file://0005-arm-omap-mcspi-follow-proper-probe-remove-steps.patch \
38         file://0006-usb-musb-cppi41_dma-Check-if-scheduling-is-required-.patch \
39         file://can/0001-can-d_can-Added-support-for-Bosch-D_CAN-controller.patch \
40         file://can/0002-can-d_can-Added-platform-data-for-am33xx-device.patch \
41         file://can/0003-can-d_can-DCAN-config-added-to-am335x_evm_defconfig.patch \
42         file://can/0004-can-d_can-fix-for-cansend-loop-issue.patch \
43         file://can/0005-can-d_can-fixes-the-rmmod-crash.patch \
44         file://i2c/0001-arm-omap-mux33xx-Add-i2c2-pin-muix.patch \
45         file://i2c/0002-omap-hwmod-33xx-Add-support-for-third-i2c-bus.patch \
46         file://i2c/0003-arm-omap-board-Add-quick-hack-to-get-i2c2-bus-suppor.patch      \
47         file://adc/0001-AM335x-Add-support-for-TSC-on-Beta-GP-EVM.patch \
48         file://adc/0002-ARM-OMAP-AM335x-Add-support-for-Beta-GP-EVM.patch \
49         file://adc/0003-AM335x-Add-support-for-pressure-measurement-on-TSC.patch \
50         file://adc/0004-tscadc-Add-general-purpose-mode-untested-with-touchs.patch \
51         file://adc/0005-tscadc-Add-board-file-mfd-support-fix-warning.patch \
52         file://adc/0006-AM335X-init-tsc-bone-style-for-new-boards.patch \
53         file://adc/0007-tscadc-make-stepconfig-channel-configurable.patch \
54         file://adc/0008-tscadc-Trigger-through-sysfs.patch \
55         file://adc/0009-meta-ti-Remove-debug-messages-for-meta-ti.patch \
56         file://adc/0010-tscadc-switch-to-polling-instead-of-interrupts.patch \
57         file://st7735fb/0001-st7735fb-WIP-framebuffer-driver-supporting-Adafruit-.patch \
58     file://0031-am335x-evm-add-pdata-for-all-cape-EEPROM-permutation.patch \
59         "
61 SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}"
62 SRC_URI_append_beaglebone = " file://logo_linux_clut224.ppm"