1 require multi-kernel.inc
3 DESCRIPTION = "Linux kernel for TI81xx processors"
4 KERNEL_IMAGETYPE = "uImage"
6 COMPATIBLE_MACHINE = "am387x-evm|am389x-evm|c6a814x-evm|c6a816x-evm|dm814x-evm"
8 # This is on the ti81xx-master branch
9 SRCREV = "5f796a09b932def4b02032521b412d9c64c8669a"
11 # requires .28 hdvpss: d686b2da5d2e7337c9759f910c3a665c27b0ec31
13 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
14 MACHINE_KERNEL_PR_append = "C+gitr${SRCREV}"
16 SRC_URI += "git://arago-project.org/git/projects/linux-omap3.git;protocol=git;branch=ti81xx-master \
17 file://defconfig"
19 S = "${WORKDIR}/git"
21 # Perf in 2.6.37-psp doesn't build, so disable it
22 do_compile_perf() {
23 :
24 }
26 do_install_perf() {
27 :
28 }