]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-misc/images/ti-hw-bringup-image.bb
2be8baf6e76f59c142b140b338aafd9fdef1ba2b
[glsdk/meta-ti-glsdk.git] / recipes-misc / images / ti-hw-bringup-image.bb
1 # Image for assisting in hardware bringup
3 include recipes-images/angstrom/systemd-image.bb
5 EXTRA_MACHINE_IMAGE_INSTALL ?= ""
7 # Hokey-pokey workaround for MUSB bugs
8 EXTRA_MACHINE_IMAGE_INSTALL_ti33x = "gadget-init"
10 IMAGE_INSTALL += " \
11         usbutils \
12         i2c-tools \
13         alsa-utils \
14         devmem2 \
15         iw \
16         bonnie++ \
17         hdparm \
18         iozone3 \
19         iperf \
20         lmbench \
21         rt-tests \
22         evtest \
23         bc \
24         task-ti-test \
25         kernel-modules \
26         timestamp-service \
27         ${EXTRA_MACHINE_IMAGE_INSTALL} \
28 "
30 export IMAGE_BASENAME = "TI-hw-bringup"
32 inherit sdcard_image