]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-misc/payload/beaglebone-getting-started.bb
beaglebone-getting-started: active bone101 webserver on boot
[glsdk/meta-ti-glsdk.git] / recipes-misc / payload / beaglebone-getting-started.bb
1 DESCRIPTION = "BeagleBone Getting Started Guide"
3 PR = "r9"
5 inherit allarch systemd
7 LICENSE = "GPLv2+ && MIT && PD && others"
8 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=603591dea023c3c75b48e07cb47ce639"
10 SRCREV = "ee3af61403b087c2882ba539d3358ba25c5b8dc7"
11 SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git \
12            file://bone101.service"
14 S = "${WORKDIR}/git"
16 do_install() {
17         install -d ${D}${datadir}/${PN}
18         cp -a ${S}/* ${D}${datadir}/${PN}
20         install -d ${D}${base_libdir}/systemd/system
21         install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system
22 }
24 SYSTEMD_PACKAGES = "${PN}"
25 SYSTEMD_SERVICE_${PN} = "bone101.service"
27 FILES_${PN} += "${datadir}/${PN} ${base_libdir}/systemd/system"