]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-misc/payload/bonescript.bb
linux-ti33x-psp 3.2: remove patch that slipped in when regenerating SRC_URI
[glsdk/meta-ti-glsdk.git] / recipes-misc / payload / bonescript.bb
1 DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone"
3 PR = "r13"
5 inherit systemd
7 LICENSE = "MIT"
8 LIC_FILES_CHKSUM = "file://LICENSE;md5=659ee0c98db2664403c769d6b9ab50eb"
10 SRC_URI = "http://dominion.thruhere.net/koen/angstrom/beaglebone/bonescript-8898f4ee4ae2548642679626a03e332a4cd43331.tar.bz2 \
11            file://bonescript-git \
12            file://bone101.service \
13           "
14 SRC_URI[md5sum] = "306278a2afc10b75f4fc886918fb02b7"
15 SRC_URI[sha256sum] = "01c87e59adcc663365c664b0731f0e5a23feeae1965a5cd5edd3e89255f8a30b"
17 S = "${WORKDIR}/bonescript"
19 do_install() {
20         install -d ${D}${localstatedir}/lib/cloud9/
21         cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/
22         cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/
24         install -d ${D}${base_libdir}/systemd/system
25         install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system
27         rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/itof
28         rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/ftoi
29 }
31 SYSTEMD_PACKAGES = "${PN}"
32 SYSTEMD_SERVICE_${PN} = "bone101.service"
34 FILES_${PN} += "${localstatedir} ${base_libdir}/systemd/system"
35 CONFFILES_${PN} += "${localstatedir}/lib/cloud9/.git/config"
36 RDEPENDS_${PN} = "nodejs cloud9"
37 RRECOMMENDS_${PN} = "git"