]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-ti/beagleboard/beaglebone-capes.bb
linux-ti-staging: add recipe for tracking TI latest staging tree
[glsdk/meta-ti-glsdk.git] / recipes-ti / beagleboard / beaglebone-capes.bb
1 DESCRIPTION = "Userspace setup for beaglebone capes"
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
6 PR = "r4"
8 inherit allarch
10 SRC_URI = "file://cape.service \
11            file://cape.sh \
12            file://cape-stop.sh \
13           "
15 do_install() {
16         install -d ${D}${base_libdir}/systemd/system/
17         install -m 0644 ${WORKDIR}/cape.service ${D}${base_libdir}/systemd/system
19         install -d ${D}${base_libdir}/systemd/system/basic.target.wants
20         ln -sf ../cape.service ${D}${base_libdir}/systemd/system/basic.target.wants/
22         install -d ${D}${bindir}
23         install -m 0755 ${WORKDIR}/cape*.sh ${D}${bindir}
24 }
26 FILES_${PN} += "${base_libdir}/systemd/system"