]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-ti/matrix/matrix-gui-clocks_1.0.bb
cloud9-image: add screen, git and minicom
[glsdk/meta-ti-glsdk.git] / recipes-ti / matrix / matrix-gui-clocks_1.0.bb
1 DESCRIPTION = "Clock setting descriptions for Matrix v2"
2 HOMEPAGE = "https://gforge.ti.com/gf/project/matrixguiv2apps/"
3 LICENSE = "CC-BY-SA"
5 inherit allarch
7 SRC_URI = "https://gforge.ti.com/gf/download/frsrelease/612/5031/clocks_1.0.tar.gz"
9 S = ${WORKDIR}/clocks
11 require matrix-gui-apps.inc
13 # Make sure power submenu has been installed
14 RDEPENDS +=  matrix-gui-submenus-power
16 # Break out the individual files into separate packages.  That way only the
17 # clocks supported for each device can be installed.  Prepend the list so
18 # that we can get the files in ${bindir} first
19 PACKAGES =+ "${PN}-300mhz ${PN}-600mhz ${PN}-800mhz ${PN}-1ghz"
21 # Split the matrix files by clock
22 FILES_${PN}-300mhz += "${MATRIX_APP_DIR}/power_set_300mhz/*"
23 FILES_${PN}-600mhz += "${MATRIX_APP_DIR}/power_set_600mhz/*"
24 FILES_${PN}-800mhz += "${MATRIX_APP_DIR}/power_set_800mhz/*"
25 FILES_${PN}-1ghz += "${MATRIX_APP_DIR}/power_set_1ghz/*"
27 # Split the ${bindir} files by clock
28 FILES_${PN}-300mhz += "${bindir}/setopp2.sh"
29 FILES_${PN}-600mhz += "${bindir}/setopp3.sh"
30 FILES_${PN}-800mhz += "${bindir}/setopp4.sh"
31 FILES_${PN}-1ghz += "${bindir}/setopp1.sh"
33 SRC_URI[md5sum] = "9e76951feab2ecd9334e9c890426500f"
34 SRC_URI[sha256sum] = "96dc90fffe45fc4bb499215f57c416d16ff874290d6b2f16b9e2fdbcb9c18cbe"