]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-ti/tasks/task-ti-test.bb
task-ti-test: import task-arago-test.bb from arago git
[glsdk/meta-ti-glsdk.git] / recipes-ti / tasks / task-ti-test.bb
1 DESCRIPTION = "Extended task to get System Test specific apps"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
5 inherit task
7 # those ones can be set in machine config to supply packages needed to get machine booting
8 MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
9 MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
11 TEST = "\
12     bonnie++ \
13     hdparm \
14     iozone3 \
15     iperf \
16     lmbench \
17     rt-tests \
18     "
20 TI_TEST = "\
21     ltp-ddt \
22     "
24 RDEPENDS_${PN} = "\
25     ${TEST} \
26     ${TI_TEST} \
27     ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
28     "
30 RRECOMMENDS_${PN} = "\
31     ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \
32     "