README: update with the latest info
[glsdk/meta-ti-glsdk.git] / README
diff --git a/README b/README
index 9c3e5ff3c6f4f5c1e0570cccb6886ef85cad97e1..9e91f8dea193e3ca06d901286a74e14d30d824ab 100644 (file)
--- a/README
+++ b/README
@@ -1,36 +1,32 @@
-This layer hard depends on:
+The official OpenEmbedded/Yocto BSP layer for Texas Instruments platforms.
+
+This layer depends on:
 
 URI: git://git.openembedded.org/openembedded-core
+layers: meta
 branch: master
 revision: HEAD
 
 URI: git://git.openembedded.org/meta-openembedded
+layers: meta-oe
 branch: master
 revision: HEAD
 
-And optionally depends on:
-
-URI: git://git.angstrom-distribution.org/meta-angstrom
-branch: master
-revision: HEAD
+There are known issues when using a toolchain with gcc-4.6 and binutils-2.22
+from OpenEmbedded-Core, thus it is recommended to use meta-openembedded layer
+with gcc-4.5 + Linaro patches and binutils-2.20.1.
 
-Currently meta-ti only works with the Angstrom distribution and hence
-requires the meta-angstrom layer. There are known issues when using
-gcc-4.6 based toolchain from OpenEmbedded-Core, thus gcc-4.5 toolchain,
-provided by meta-openembedded, is needed. It is planned to fix these
-shortcomings in the near future and allow building the base BSP part
-of meta-ti with different distributions and layer stacks, such as:
-distro-less (only with OE-Core), with Yocto/Poky, with Angstrom or
-Arago.
+The base BSP part of meta-ti should work with different OpenEmbedded/Yocto
+distributions and layer stacks, such as:
+distro-less (only with OE-Core), with Yocto/Poky, with Angstrom or Arago.
 
-Due to the above, it is now recommended to follow the instructions at
-http://www.angstrom-distribution.org/building-angstrom
+Please follow the recommended setup procedures of your OE distribution. When
+using in a distro-less configuration, please add to your local.conf:
 
-This will set it up for the OpenEmbedded-core ('yocto') layout instead
-of the old "Classic" OpenEmbedded-dev layout. You can optionally tweak
-sources/layers.txt and conf/bblayers.conf to (de)select BSP layers.
+GCCVERSION = "4.5%"
+BINUVERSION = "2.20.1"
 
-Send pull requests to meta-ti@yoctoproject.org
+Send pull requests, patches, comments or questions to meta-ti@yoctoproject.org
 
-Main layer maintainers: Denys Dmytriyenko <denys@ti.com>
-                        Koen Kooi <k-kooi@ti.com>
+Maintainers: Denys Dmytriyenko <denys@ti.com>
+             Koen Kooi <koen@dominion.thruhere.net>