]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blobdiff - recipes-bsp/u-boot/u-boot_2011.10rc.bb
u-boot: Fix config-Always-use-GNU-ld patch to work with dash
[glsdk/meta-ti-glsdk.git] / recipes-bsp / u-boot / u-boot_2011.10rc.bb
index 44ebeb635cca73a2ed03ad4906adf85df5780d18..0102d15eb6952f2799b08731887eff0228f97202 100644 (file)
@@ -1,27 +1,34 @@
 require u-boot.inc
 
 # No patches for other machines yet
-COMPATIBLE_MACHINE = "beaglebone"
-DEFAULT_PREFERENCE_beaglebone = "99"
+COMPATIBLE_MACHINE = "(ti33x)"
+
+DEFAULT_PREFERENCE_ti33x = "99"
+
 PV = "2011.09+git"
-PR = "r5"
+PR = "r26"
 
 # SPL build
 UBOOT_BINARY = "u-boot.img"
 UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
 UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
 
-SRC_URI = "git://github.com/trini/u-boot.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \
-           file://2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch \
-           file://2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch \
+SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \
+           file://2011.09git/0001-am335x_evm-only-do-in-kernel-dhcp-when-using-NFS-use.patch \
+           file://2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch \
+           file://2011.09git/0003-am335x_evm-set-bootdelay-to-1.patch \
+           file://2011.09git/0004-am335x-evm-make-MMC-rootfs-RO-on-boot-so-fsck-works.patch \
+           file://2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch \
+           file://2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch \
+           file://2011.09git/0007-am335x_evm-switch-to-ext4.patch \
+           file://2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch \
+           file://2011.09git/0009-am335x-evm-enable-i2c2-pinmux-for-beaglebone.patch \
+           file://2011.09git/0001-ddr_defs-change-DDR-timings-for-15x15-EVM.patch \
           "
 
-SRCREV = "456880b203bc44c025c374c98fa327b804a9cf64"
+SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
 
 S = "${WORKDIR}/git"
 
-do_deploy_append () {
-    install ${S}/MLO ${DEPLOY_DIR_IMAGE}/MLO
-}