]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blobdiff - recipes-kernel/linux/linux-ti-staging_git.bb
linux-ti-staging: update to the latest merge of 3.8.3
[glsdk/meta-ti-glsdk.git] / recipes-kernel / linux / linux-ti-staging_git.bb
index 5f4a05ddd21df607887c6caf6b299900ab27a265..cfd4da00896264b66206235e779c5c783ec69ea9 100644 (file)
@@ -5,6 +5,22 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
 KERNEL_IMAGETYPE = "uImage"
 
 inherit kernel
+
+# This function must be here BEFORE the require of linux-dtb.inc below.
+# There is a "bug" in the base kernel.bbclass that after it's do_deploy
+# step it does not return back to the ${S} directory but stays in the
+# DEPLOY_DIR.  However, the do_deploy_append defined in linux-dtb.inc
+# assumes that it is being run in the ${S} directory.  A patch is
+# being submitted to fix this issue by either changing the do_deploy
+# in the kernel.bbclass to do "cd -" as the last step or to add
+# "cd ${S}" as the first line of do_deploy in linux-dtb.inc and this
+# function can be removed once that change is available.
+# If the function is not placed BEFORE the require then the change
+# directory is not appended before the linux-dtb.inc changes.
+do_deploy_append() {
+    cd ${S}
+}
+
 require recipes-kernel/linux/linux-dtb.inc
 require recipes-kernel/linux/setup-defconfig.inc
 
@@ -12,7 +28,9 @@ require recipes-kernel/linux/setup-defconfig.inc
 # for ti33x SOC_FAMILY devices
 DEPENDS_ti33x += "am33x-cm3"
 
-KERNEL_DEVICETREE_am335x-evm = "arch/arm/boot/dts/am335x-evm.dts"
+# Default is to package all dts files for ti33x devices unless building
+# for the specific beaglebone machine.
+KERNEL_DEVICETREE_ti33x = "arch/arm/boot/dts/am335x-evm.dts arch/arm/boot/dts/am335x-evmsk.dts arch/arm/boot/dts/am335x-bone.dts"
 KERNEL_DEVICETREE_beaglebone = "arch/arm/boot/dts/am335x-bone.dts"
 
 COMPATIBLE_MACHINE = "ti33x"
@@ -21,13 +39,13 @@ S = "${WORKDIR}/git"
 
 BRANCH = "ti-linux-3.8.y"
 
-SRCREV = "d26595a42220789b81a9d243e2fc0837c7776360"
-PV = "3.8.2"
+SRCREV = "ed93a28fb0b1dc28cc252ee87f6fce3e07bf23fe"
+PV = "3.8.3"
 
 # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
-MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}"
+MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
 
-SRC_URI = "git://gitorious.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
+SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
            file://defconfig \
           "