]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blobdiff - recipes-kernel/linux/linux-ti33x-psp_3.1.bb
linux-ti33x-psp: Check if scheduling is required after DMA
[glsdk/meta-ti-glsdk.git] / recipes-kernel / linux / linux-ti33x-psp_3.1.bb
index b90f4b36ccc442dc78080595ae1d18e8ba51e6f6..37f59cad635fc457bab5506d1c180610d2107d59 100644 (file)
@@ -9,9 +9,9 @@ S = "${WORKDIR}/git"
 
 MULTI_CONFIG_BASE_SUFFIX = ""
 
-BRANCH = "master"
-SRCREV = "fd97d5068496ab770991a263e9046781ca2441a5"
-MACHINE_KERNEL_PR_append = "l+gitr${SRCREV}"
+BRANCH = "v3.1-staging"
+SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d"
+MACHINE_KERNEL_PR_append = "r+gitr${SRCREV}"
 
 COMPATIBLE_MACHINE = "(ti33x)"
 
@@ -26,10 +26,24 @@ SRC_URI += "git://arago-project.org/git/projects/linux-am33x.git;protocol=git;br
 
 PATCHES_OVER_PSP = " \
        file://0001-f_rndis-HACK-around-undefined-variables.patch \
-       file://0001-am335x-Add-pin-mux-and-init-for-beaglebone-specific-.patch \
-       file://0001-am335x-Check-return-value-of-omap_mux_init_signal.patch \
-       file://0002-at24-Add-ability-to-dynamically-reconfigure-chip-inf.patch \
-       file://0003-am335x-evm-Reconfigure-EEPROM-with-new-eeprom_info-in.patch \
+       file://0001-ARM-omap-am335x-BeagleBone-version-detection-and-sup.patch \
+       file://0002-ARM-OMAP2-beaglebone-add-LED-support.patch \
+       file://0003-ARM-OMAP2-beaglebone-add-DVI-support-needs-cleanup.patch \
+       file://0004-da8xx-fb-add-DVI-support-for-beaglebone.patch \
+       file://0001-usb-musb_core-kill-all-global-and-static-variables.patch \
+       file://0002-arm-omap-am335x-correct-32KHz-clk-rate.patch \
+       file://0003-arm-omap-mcspi-correct-memory-range-when-requesting-.patch \
+       file://0004-arm-omap-mcspi-follow-proper-pm_runtime-enable-disab.patch \
+       file://0005-arm-omap-mcspi-follow-proper-probe-remove-steps.patch \
+       file://0006-usb-musb-cppi41_dma-Check-if-scheduling-is-required-.patch \
+       file://can/0001-can-d_can-Added-support-for-Bosch-D_CAN-controller.patch \
+       file://can/0002-can-d_can-Added-platform-data-for-am33xx-device.patch \
+       file://can/0003-can-d_can-DCAN-config-added-to-am335x_evm_defconfig.patch \
+       file://can/0004-can-d_can-fix-for-cansend-loop-issue.patch \
+       file://can/0005-can-d_can-fixes-the-rmmod-crash.patch \
+       file://can/0007-can-d_can-am335x-profile-modification-for-dcan0.patch \
        "
 
 SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}"
+SRC_URI_append_beaglebone = " file://logo_linux_clut224.ppm"
+