]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blobdiff - recipes-kernel/linux/linux-ti33x-psp_3.1.bb
linux-ti335x-psp 3.1: add support for ST7735FB, but don't enable it in the beaglebone...
[glsdk/meta-ti-glsdk.git] / recipes-kernel / linux / linux-ti33x-psp_3.1.bb
index 836c5f82ad3b45a691a658ab5748ce98505f6512..46687493cd37f357ec8496e3cef7d53f1e28b60d 100644 (file)
@@ -9,9 +9,9 @@ S = "${WORKDIR}/git"
 
 MULTI_CONFIG_BASE_SUFFIX = ""
 
-BRANCH = "v3.1-staging"
+BRANCH = "v3.1-meta-ti-r1r+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d"
 SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d"
-MACHINE_KERNEL_PR_append = "q+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "e+gitr${SRCREV}"
 
 COMPATIBLE_MACHINE = "(ti33x)"
 
@@ -21,7 +21,7 @@ ${@base_set_filespath(["${THISDIR}/${PN}/tipspkernel"], d)}:\
 ${@base_set_filespath(["${THISDIR}/files/tipspkernel"], d)}:"
 FILESPATH =. "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "${CONFIGS_PSP}", "", d)}"
 
-SRC_URI += "git://arago-project.org/git/projects/linux-am33x.git;protocol=git;branch=${BRANCH} \
+SRC_URI += "git://github.com/beagleboard/linux.git;branch=${BRANCH} \
        file://defconfig"
 
 PATCHES_OVER_PSP = " \
@@ -35,6 +35,26 @@ PATCHES_OVER_PSP = " \
        file://0003-arm-omap-mcspi-correct-memory-range-when-requesting-.patch \
        file://0004-arm-omap-mcspi-follow-proper-pm_runtime-enable-disab.patch \
        file://0005-arm-omap-mcspi-follow-proper-probe-remove-steps.patch \
+       file://0006-usb-musb-cppi41_dma-Check-if-scheduling-is-required-.patch \
+       file://can/0001-can-d_can-Added-support-for-Bosch-D_CAN-controller.patch \
+       file://can/0002-can-d_can-Added-platform-data-for-am33xx-device.patch \
+       file://can/0003-can-d_can-DCAN-config-added-to-am335x_evm_defconfig.patch \
+       file://can/0004-can-d_can-fix-for-cansend-loop-issue.patch \
+       file://can/0005-can-d_can-fixes-the-rmmod-crash.patch \
+       file://i2c/0001-arm-omap-mux33xx-Add-i2c2-pin-muix.patch \
+       file://i2c/0002-omap-hwmod-33xx-Add-support-for-third-i2c-bus.patch \
+       file://i2c/0003-arm-omap-board-Add-quick-hack-to-get-i2c2-bus-suppor.patch      \
+       file://adc/0001-AM335x-Add-support-for-TSC-on-Beta-GP-EVM.patch \
+       file://adc/0002-ARM-OMAP-AM335x-Add-support-for-Beta-GP-EVM.patch \
+       file://adc/0003-AM335x-Add-support-for-pressure-measurement-on-TSC.patch \
+       file://adc/0004-tscadc-Add-general-purpose-mode-untested-with-touchs.patch \
+       file://adc/0005-tscadc-Add-board-file-mfd-support-fix-warning.patch \
+       file://adc/0006-AM335X-init-tsc-bone-style-for-new-boards.patch \
+       file://adc/0007-tscadc-make-stepconfig-channel-configurable.patch \
+       file://adc/0008-tscadc-Trigger-through-sysfs.patch \
+       file://adc/0009-meta-ti-Remove-debug-messages-for-meta-ti.patch \
+       file://adc/0010-tscadc-switch-to-polling-instead-of-interrupts.patch \
+       file://st7735fb/0001-st7735fb-WIP-framebuffer-driver-supporting-Adafruit-.patch \
        "
 
 SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}"