]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blobdiff - recipes-kernel/linux/linux-ti33x-psp_3.2.bb
linux-ti33x-psp 3.2: fix audio/spidev clash on beaglebone
[glsdk/meta-ti-glsdk.git] / recipes-kernel / linux / linux-ti33x-psp_3.2.bb
index 4c144e51e57b4bad7192baa785c99dbb33922e4e..ab42c44277de0c67e3502983fcaa0dafbf8d1057 100644 (file)
@@ -10,9 +10,12 @@ S = "${WORKDIR}/git"
 
 MULTI_CONFIG_BASE_SUFFIX = ""
 
+# the PATCHES_OVER_PSP updates it to 3.2.x, so adjust PV to match
+PV = "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "3.2", "3.2.21", d)}"
+
 BRANCH = "v3.2-staging"
 SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01"
-MACHINE_KERNEL_PR_append = "b+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "c+gitr${SRCREV}"
 
 COMPATIBLE_MACHINE = "(ti33x)"
 
@@ -35,6 +38,25 @@ PATCHES_OVER_PSP = " \
        file://usb/0004-usb-gadget-udc-core-fix-asymmetric-calls-in-remove_d.patch \
        file://usb/0005-usb-gadget-udc-core-fix-wrong-call-order.patch \
        file://usb/0006-usb-gadget-udc-core-fix-incompatibility-with-dummy-h.patch \
+       file://psp/0001-ARM-OMAP-AM33XX-Add-missing-EMIF-register-offsets.patch \
+       file://psp/0002-ARM-OMAP-AM33XX-PM-Get-rid-of-hardcoded-resume-addre.patch \
+       file://psp/0003-ARM-OMAP-AM33XX-PM-Skip-DDR-PHY-reconfiguration-in-r.patch \
+       file://psp/0004-ARM-OMAP-AM33XX-PM-Save-and-restore-EMIF-registers.patch \
+       file://psp/0005-ARM-OMAP-AM33XX-PM-Wait-correctly-for-the-PLLs-to-re.patch \
+       file://psp/0006-ARM-OMAP-AM33XX-PM-Restore-the-PLLs-to-pre-suspend-s.patch \
+       file://psp/0007-ARM-OMAP-PM-AM33XX-Update-the-sleep-code-to-handle-D.patch \
+       file://psp/0008-usb-musb-update-babble-workaround-fix.patch \
+       file://psp/0009-usb-musb-ti81xx-print-the-usbss-revision-id-during-i.patch \
+       file://psp/0010-usb-musb-cppi41-enable-txfifo-empty-interrupt-logic.patch \
+       file://psp/0011-usb-musb-host-Flush-txfifo-only-if-TxPktRdy-bit-set.patch \
+       file://psp/0012-usb-musb-cppi41-use-dsb-to-make-sure-PDs-are-updated.patch \
+       file://psp/0013-usb-musb-cppi41-fix-zero-byte-OUT-issue.patch \
+       file://psp/0014-usb-musb-host-fix-for-urb-error-handling.patch \
+       file://psp/0015-usb-musb-cppi41-txdma-flushfifo-fixes-during-channel.patch \
+       file://psp/0016-usb-musb-cppi41-tx-dma-completion-fixes.patch \
+       file://psp/0017-usb-musb-host-Flush-RxFIFO-only-when-RxPktRdy-is-set.patch \
+       file://psp/0018-usb-musb-ti81xx-fix-role-switching-issue.patch \
+       file://psp/0019-MMC-OMAP-HS-Enable-HSPE-bit-for-high-speed-cards.patch \
        file://3.2.1/0001-MAINTAINERS-stable-Update-address.patch \
        file://3.2.1/0002-Documentation-Update-stable-address.patch \
        file://3.2.1/0003-firmware-Fix-an-oops-on-reading-fw_priv-fw-in-sysfs-.patch \
@@ -1153,7 +1175,293 @@ PATCHES_OVER_PSP = " \
        file://3.2.18/0054-pktgen-fix-crash-at-module-unload.patch \
        file://3.2.18/0055-pktgen-fix-module-unload-for-good.patch \
        file://3.2.18/0056-Linux-3.2.18.patch \
+       file://3.2.19/0001-KVM-mmu_notifier-Flush-TLBs-before-releasing-mmu_loc.patch \
+       file://3.2.19/0002-KVM-Ensure-all-vcpus-are-consistent-with-in-kernel-i.patch \
+       file://3.2.19/0003-KVM-lock-slots_lock-around-device-assignment.patch \
+       file://3.2.19/0004-KVM-nVMX-Fix-erroneous-exception-bitmap-check.patch \
+       file://3.2.19/0005-KVM-VMX-vmx_set_cr0-expects-kvm-srcu-locked.patch \
+       file://3.2.19/0006-KVM-s390-do-store-status-after-handling-STOP_ON_STOP.patch \
+       file://3.2.19/0007-KVM-s390-Sanitize-fpc-registers-for-KVM_SET_FPU.patch \
+       file://3.2.19/0008-bio-don-t-overflow-in-bio_get_nr_vecs.patch \
+       file://3.2.19/0009-bio-allocation-failure-due-to-bio_get_nr_vecs.patch \
+       file://3.2.19/0010-block-fix-buffer-overflow-when-printing-partition-UU.patch \
+       file://3.2.19/0011-fix-PA1.1-oops-on-boot.patch \
+       file://3.2.19/0012-fix-crash-in-flush_icache_page_asm-on-PA1.1.patch \
+       file://3.2.19/0013-fix-panic-on-prefetch-NULL-on-PA7300LC.patch \
+       file://3.2.19/0014-arch-tile-Kconfig-remove-pointless-M386-test.patch \
+       file://3.2.19/0015-tilegx-enable-SYSCALL_WRAPPERS-support.patch \
+       file://3.2.19/0016-mtd-sm_ftl-fix-typo-in-major-number.patch \
+       file://3.2.19/0017-hpsa-Fix-problem-with-MSA2xxx-devices.patch \
+       file://3.2.19/0018-SELinux-if-sel_make_bools-errors-don-t-leave-inconsi.patch \
+       file://3.2.19/0019-cfg80211-warn-if-db.txt-is-empty-with-CONFIG_CFG8021.patch \
+       file://3.2.19/0020-mpt2sas-Fix-for-panic-happening-because-of-improper-.patch \
+       file://3.2.19/0021-isdn-gigaset-ratelimit-CAPI-message-dumps.patch \
+       file://3.2.19/0022-isdn-gigaset-fix-CAPI-disconnect-B3-handling.patch \
+       file://3.2.19/0023-isdn-gigaset-improve-error-handling-querying-firmwar.patch \
+       file://3.2.19/0024-KEYS-Use-the-compat-keyctl-syscall-wrapper-on-Sparc6.patch \
+       file://3.2.19/0025-IB-core-Fix-mismatch-between-locked-and-pinned-pages.patch \
+       file://3.2.19/0026-regulator-core-Release-regulator-regulator-supplies-.patch \
+       file://3.2.19/0027-iommu-Fix-off-by-one-in-dmar_get_fault_reason.patch \
+       file://3.2.19/0028-RDMA-cxgb4-Always-wake-up-waiters-in-c4iw_peer_abort.patch \
+       file://3.2.19/0029-RDMA-cxgb4-Drop-peer_abort-when-no-endpoint-found.patch \
+       file://3.2.19/0030-s390-pfault-fix-task-state-race.patch \
+       file://3.2.19/0031-isci-fix-oem-parameter-validation-on-single-controll.patch \
+       file://3.2.19/0032-Fix-blocking-allocations-called-very-early-during-bo.patch \
+       file://3.2.19/0033-vfs-make-AIO-use-the-proper-rw_verify_area-area-help.patch \
+       file://3.2.19/0034-docs-update-HOWTO-for-2.6.x-3.x-versioning.patch \
+       file://3.2.19/0035-drivers-staging-comedi-comedi_fops.c-add-missing-vfr.patch \
+       file://3.2.19/0036-USB-move-usb_translate_errors-to-linux-usb.h.patch \
+       file://3.2.19/0037-USB-cdc-wdm-sanitize-error-returns.patch \
+       file://3.2.19/0038-USB-cdc-wdm-fix-memory-leak.patch \
+       file://3.2.19/0039-8250_pci-fix-pch-uart-matching.patch \
+       file://3.2.19/0040-usb-add-USB_QUIRK_RESET_RESUME-for-M-Audio-88es.patch \
+       file://3.2.19/0041-usb-usbtest-two-super-speed-fixes-for-usbtest.patch \
+       file://3.2.19/0042-8250.c-less-than-2400-baud-fix.patch \
+       file://3.2.19/0043-usb-xhci-Handle-COMP_TX_ERR-for-isoc-tds.patch \
+       file://3.2.19/0044-xhci-Avoid-dead-ports-when-CONFIG_USB_XHCI_HCD-n.patch \
+       file://3.2.19/0045-xhci-Add-Lynx-Point-to-list-of-Intel-switchable-host.patch \
+       file://3.2.19/0046-usb-gadget-fsl_udc_core-dTD-s-next-dtd-pointer-need-.patch \
+       file://3.2.19/0047-Add-missing-call-to-uart_update_timeout.patch \
+       file://3.2.19/0048-USB-ftdi-sio-add-support-for-Physik-Instrumente-E-86.patch \
+       file://3.2.19/0049-USB-ffs-test-fix-length-argument-of-out-function-cal.patch \
+       file://3.2.19/0050-HID-wiimote-Fix-IR-data-parser.patch \
+       file://3.2.19/0051-usb-storage-unusual_devs-entry-for-Yarvik-PMP400-MP4.patch \
+       file://3.2.19/0052-USB-ohci-at91-add-a-reset-function-to-fix-race-condi.patch \
+       file://3.2.19/0053-HID-logitech-read-all-32-bits-of-report-type-bitfiel.patch \
+       file://3.2.19/0054-USB-serial-ti_usb_3410_5052-Add-support-for-the-FRI2.patch \
+       file://3.2.19/0055-USB-cdc-wdm-poll-must-return-POLLHUP-if-device-is-go.patch \
+       file://3.2.19/0056-USB-cdc-wdm-add-debug-messages-on-cleanup.patch \
+       file://3.2.19/0057-USB-cdc-wdm-cannot-use-dev_printk-when-device-is-gon.patch \
+       file://3.2.19/0058-tty-Allow-uart_register-unregister-register.patch \
+       file://3.2.19/0059-workqueue-skip-nr_running-sanity-check-in-worker_ent.patch \
+       file://3.2.19/0060-xhci-Add-new-short-TX-quirk-for-Fresco-Logic-host.patch \
+       file://3.2.19/0061-usbcore-enable-USB2-LPM-if-port-suspend-fails.patch \
+       file://3.2.19/0062-perf-x86-Update-event-scheduling-constraints-for-AMD.patch \
+       file://3.2.19/0063-USB-fix-resource-leak-in-xhci-power-loss-path.patch \
+       file://3.2.19/0064-xhci-Reset-reserved-command-ring-TRBs-on-cleanup.patch \
+       file://3.2.19/0065-USB-Remove-races-in-devio.c.patch \
+       file://3.2.19/0066-md-using-GFP_NOIO-to-allocate-bio-for-flush-request.patch \
+       file://3.2.19/0067-um-Implement-a-custom-pte_same-function.patch \
+       file://3.2.19/0068-um-Fix-__swp_type.patch \
+       file://3.2.19/0069-swap-don-t-do-discard-if-no-discard-option-added.patch \
+       file://3.2.19/0070-Input-wacom-relax-Bamboo-stylus-ID-check.patch \
+       file://3.2.19/0071-ahci-Detect-Marvell-88SE9172-SATA-controller.patch \
+       file://3.2.19/0072-ARM-7365-1-drop-unused-parameter-from-flush_cache_us.patch \
+       file://3.2.19/0073-ARM-7409-1-Do-not-call-flush_cache_user_range-with-m.patch \
+       file://3.2.19/0074-sony-laptop-Enable-keyboard-backlight-by-default.patch \
+       file://3.2.19/0075-init-don-t-try-mounting-device-as-nfs-root-unless-ty.patch \
+       file://3.2.19/0076-memcg-free-spare-array-to-avoid-memory-leak.patch \
+       file://3.2.19/0077-compat-Fix-RT-signal-mask-corruption-via-sigprocmask.patch \
+       file://3.2.19/0078-ext3-Fix-error-handling-on-inode-bitmap-corruption.patch \
+       file://3.2.19/0079-ext4-fix-error-handling-on-inode-bitmap-corruption.patch \
+       file://3.2.19/0080-ACPI-PM-Add-Sony-Vaio-VPCCW29FX-to-nonvs-blacklist.patch \
+       file://3.2.19/0081-hpsa-Add-IRQF_SHARED-back-in-for-the-non-MSI-X-inter.patch \
+       file://3.2.19/0082-wake-up-s_wait_unfrozen-when-freeze_fs-fails.patch \
+       file://3.2.19/0083-cifs-fix-revalidation-test-in-cifs_llseek.patch \
+       file://3.2.19/0084-dl2k-Clean-up-rio_ioctl.patch \
+       file://3.2.19/0085-OMAPDSS-VENC-fix-NULL-pointer-dereference-in-DSS2-VE.patch \
+       file://3.2.19/0086-i2c-eg20t-change-timeout-value-50msec-to-1000msec.patch \
+       file://3.2.19/0087-drm-i915-GEN7-Use-HW-scheduler-for-fixed-function-sh.patch \
+       file://3.2.19/0088-mmc-sdio-avoid-spurious-calls-to-interrupt-handlers.patch \
+       file://3.2.19/0089-smsusb-add-autodetection-support-for-USB-ID-2040-c0a.patch \
+       file://3.2.19/0090-uvcvideo-Fix-ENUMINPUT-handling.patch \
+       file://3.2.19/0091-drm-i915-Avoid-a-double-read-of-PCH_IIR-during-inter.patch \
+       file://3.2.19/0092-b43legacy-Fix-error-due-to-MMIO-access-with-SSB-unpo.patch \
+       file://3.2.19/0093-gpio-mpc8xxx-Prevent-NULL-pointer-deref-in-demux-han.patch \
+       file://3.2.19/0094-drm-i915-don-t-clobber-the-pipe-param-in-sanitize_mo.patch \
+       file://3.2.19/0095-spi-spi-fsl-spi-reference-correct-pdata-in-fsl_spi_c.patch \
+       file://3.2.19/0096-xen-do-not-map-the-same-GSI-twice-in-PVHVM-guests.patch \
+       file://3.2.19/0097-nouveau-nouveau_set_bo_placement-takes-TTM-flags.patch \
+       file://3.2.19/0098-MCE-Fix-vm86-handling-for-32bit-mce-handler.patch \
+       file://3.2.19/0099-x86-mce-Fix-check-for-processor-context-when-machine.patch \
+       file://3.2.19/0100-tile-fix-bug-where-fls-0-was-not-returning-0.patch \
+       file://3.2.19/0101-intel-iommu-Add-device-info-into-list-before-doing-c.patch \
+       file://3.2.19/0102-ethtool-Null-terminate-filename-passed-to-ethtool_op.patch \
+       file://3.2.19/0103-block-don-t-mark-buffers-beyond-end-of-disk-as-mappe.patch \
+       file://3.2.19/0104-drivers-rtc-rtc-pl031.c-configure-correct-wday-for-2.patch \
+       file://3.2.19/0105-rtlwifi-Preallocate-USB-read-buffers-and-eliminate-k.patch \
+       file://3.2.19/0106-NFS4-fix-compile-warnings-in-nfs4proc.c.patch \
+       file://3.2.19/0107-Avoid-reading-past-buffer-when-calling-GETACL.patch \
+       file://3.2.19/0108-Avoid-beyond-bounds-copy-while-caching-ACL.patch \
+       file://3.2.19/0109-i2c-tegra-notify-transfer-complete-after-clearing-st.patch \
+       file://3.2.19/0110-i2c-davinci-Free-requested-IRQ-in-remove.patch \
+       file://3.2.19/0111-x86-realmode-16-bit-real-mode-code-support-for-reloc.patch \
+       file://3.2.19/0112-x86-relocs-Workaround-for-binutils-2.22.52.0.1-secti.patch \
+       file://3.2.19/0113-x86-relocs-When-printing-an-error-say-relative-or-ab.patch \
+       file://3.2.19/0114-x86-relocs-Build-clean-fix.patch \
+       file://3.2.19/0115-x86-32-relocs-Whitelist-more-symbols-for-ld-bug-work.patch \
+       file://3.2.19/0116-x86-relocs-Add-jiffies-and-jiffies_64-to-the-relativ.patch \
+       file://3.2.19/0117-Linux-3.2.19.patch \
+       file://3.2.20/0001-iommu-amd-Add-workaround-for-event-log-erratum.patch \
+       file://3.2.20/0002-MIPS-BCM63XX-Add-missing-include-for-bcm63xx_gpio.h.patch \
+       file://3.2.20/0003-cifs-Include-backup-intent-search-flags-during-searc.patch \
+       file://3.2.20/0004-sunrpc-fix-loss-of-task-tk_status-after-rpc_delay-ca.patch \
+       file://3.2.20/0005-exofs-Fix-CRASH-on-very-early-IO-errors.patch \
+       file://3.2.20/0006-cifs-fix-oops-while-traversing-open-file-list-try-4.patch \
+       file://3.2.20/0007-Fix-dm-multipath-starvation-when-scsi-host-is-busy.patch \
+       file://3.2.20/0008-ixp4xx-fix-compilation-by-adding-gpiolib-support.patch \
+       file://3.2.20/0009-drm-i915-properly-handle-interlaced-bit-for-sdvo-dtd.patch \
+       file://3.2.20/0010-drm-i915-enable-vdd-when-switching-off-the-eDP-panel.patch \
+       file://3.2.20/0011-drm-i915-Add-Clientron-E830-to-the-ignore-LVDS-list.patch \
+       file://3.2.20/0012-drm-i915-Ignore-LVDS-on-hp-t5745-and-hp-st5747-thin-.patch \
+       file://3.2.20/0013-drm-i915-no-lvds-quirk-for-HP-t5740e-Thin-Client.patch \
+       file://3.2.20/0014-drm-i915-wait-for-a-vblank-to-pass-after-tv-detect.patch \
+       file://3.2.20/0015-drm-i915-Update-GEN6_RP_CONTROL-definitions.patch \
+       file://3.2.20/0016-drm-i915-always-use-RPNSWREQ-for-turbo-change-reques.patch \
+       file://3.2.20/0017-solos-pci-Fix-DMA-support.patch \
+       file://3.2.20/0018-microblaze-Do-not-select-GENERIC_GPIO-by-default.patch \
+       file://3.2.20/0019-fix-boot-failure-on-32-bit-systems-caused-by-branch-.patch \
+       file://3.2.20/0020-fix-TLB-fault-path-on-PA2.0-narrow-systems.patch \
+       file://3.2.20/0021-iwlwifi-update-BT-traffic-load-states-correctly.patch \
+       file://3.2.20/0022-iwlwifi-do-not-use-shadow-registers-by-default.patch \
+       file://3.2.20/0023-wl1251-fix-oops-on-early-interrupt.patch \
+       file://3.2.20/0024-NFSv4-Map-NFS4ERR_SHARE_DENIED-into-an-EACCES-error-.patch \
+       file://3.2.20/0025-drm-radeon-fix-XFX-quirk.patch \
+       file://3.2.20/0026-ath9k-fix-a-use-after-free-bug-when-ath_tx_setup_buf.patch \
+       file://3.2.20/0027-mac80211-fix-ADDBA-declined-after-suspend-with-wowla.patch \
+       file://3.2.20/0028-mm-fork-fix-overflow-in-vma-length-when-copying-mmap.patch \
+       file://3.2.20/0029-mm-consider-all-swapped-back-pages-in-used-once-logi.patch \
+       file://3.2.20/0030-hugetlb-fix-resv_map-leak-in-error-path.patch \
+       file://3.2.20/0031-mm-vmalloc.c-change-void-into-explict-vm_struct.patch \
+       file://3.2.20/0032-mm-fix-faulty-initialization-in-vmalloc_init.patch \
+       file://3.2.20/0033-fix-scsi_wait_scan.patch \
+       file://3.2.20/0034-mm-fix-vma_resv_map-NULL-pointer.patch \
+       file://3.2.20/0035-x86-amd-xen-Avoid-NULL-pointer-paravirt-references.patch \
+       file://3.2.20/0036-slub-fix-a-memory-leak-in-get_partial_node.patch \
+       file://3.2.20/0037-ext4-force-ro-mount-if-ext4_setup_super-fails.patch \
+       file://3.2.20/0038-ext4-disallow-hard-linked-directory-in-ext4_lookup.patch \
+       file://3.2.20/0039-mtd-nand-fix-scan_read_raw_oob.patch \
+       file://3.2.20/0040-vfs-increment-iversion-when-a-file-is-truncated.patch \
+       file://3.2.20/0041-vfs-umount_tree-might-be-called-on-subtree-that-had-.patch \
+       file://3.2.20/0042-ext4-add-missing-save_error_info-to-ext4_error.patch \
+       file://3.2.20/0043-ALSA-usb-audio-fix-rate_list-memory-leak.patch \
+       file://3.2.20/0044-ext4-add-ext4_mb_unload_buddy-in-the-error-path.patch \
+       file://3.2.20/0045-ext4-remove-mb_groups-before-tearing-down-the-buddy_.patch \
+       file://3.2.20/0046-drm-radeon-fix-bank-information-in-tiling-config.patch \
+       file://3.2.20/0047-drm-radeon-properly-program-gart-on-rv740-juniper-cy.patch \
+       file://3.2.20/0048-drm-radeon-fix-HD6790-HD6570-backend-programming.patch \
+       file://3.2.20/0049-drm-ttm-Fix-spinlock-imbalance.patch \
+       file://3.2.20/0050-drm-vmwgfx-Fix-nasty-write-past-alloced-memory-area.patch \
+       file://3.2.20/0051-mtd-of_parts-fix-breakage-in-Kconfig.patch \
+       file://3.2.20/0052-fec_mpc52xx-fix-timestamp-filtering.patch \
+       file://3.2.20/0053-Bluetooth-btusb-Add-vendor-specific-ID-0a5c-21f3-for.patch \
+       file://3.2.20/0054-Bluetooth-btusb-add-support-for-BCM20702A0-0a5c-21e6.patch \
+       file://3.2.20/0055-Bluetooth-btusb-Add-USB-device-ID-0a5c-21e8.patch \
+       file://3.2.20/0056-Bluetooth-btusb-typo-in-Broadcom-SoftSailing-id.patch \
+       file://3.2.20/0057-Bluetooth-btusb-Add-vendor-specific-ID-0489-e042-for.patch \
+       file://3.2.20/0058-Bluetooth-Add-support-for-Atheros-13d3-3362.patch \
+       file://3.2.20/0059-Bluetooth-Add-support-for-AR3012-0cf3-e004.patch \
+       file://3.2.20/0060-Add-Foxconn-Hon-Hai-IDs-for-btusb-module.patch \
+       file://3.2.20/0061-Bluetooth-Add-support-for-Foxconn-Hon-Hai-AR5BBU22-0.patch \
+       file://3.2.20/0062-drm-i915-Disable-FBC-on-SandyBridge.patch \
+       file://3.2.20/0063-ipv4-Do-not-use-dead-fib_info-entries.patch \
+       file://3.2.20/0064-ipv4-fix-the-rcu-race-between-free_fib_info-and-ip_r.patch \
+       file://3.2.20/0065-set-fake_rtable-s-dst-to-NULL-to-avoid-kernel-Oops.patch \
+       file://3.2.20/0066-ipv6-fix-incorrect-ipsec-fragment.patch \
+       file://3.2.20/0067-l2tp-fix-oops-in-L2TP-IP-sockets-for-connect-AF_UNSP.patch \
+       file://3.2.20/0068-r8169-missing-barriers.patch \
+       file://3.2.20/0069-r8169-fix-early-queue-wake-up.patch \
+       file://3.2.20/0070-r8169-fix-unsigned-int-wraparound-with-TSO.patch \
+       file://3.2.20/0071-Revert-net-maintain-namespace-isolation-between-vlan.patch \
+       file://3.2.20/0072-sctp-check-cached-dst-before-using-it.patch \
+       file://3.2.20/0073-skb-avoid-unnecessary-reallocations-in-__skb_cow.patch \
+       file://3.2.20/0074-xfrm-take-net-hdr-len-into-account-for-esp-payload-s.patch \
+       file://3.2.20/0075-ACPI-battery-only-refresh-the-sysfs-files-when-perti.patch \
+       file://3.2.20/0076-target-file-Use-O_DSYNC-by-default-for-FILEIO-backen.patch \
+       file://3.2.20/0077-iommu-amd-Cache-pdev-pointer-to-root-bridge.patch \
+       file://3.2.20/0078-drm-radeon-kms-add-new-Palm-Sumo-PCI-ids.patch \
+       file://3.2.20/0079-drm-radeon-kms-add-new-BTC-PCI-ids.patch \
+       file://3.2.20/0080-btree-fix-tree-corruption-in-btree_get_prev.patch \
+       file://3.2.20/0081-kbuild-install-kernel-page-flags.h.patch \
+       file://3.2.20/0082-asix-allow-full-size-8021Q-frames-to-be-received.patch \
+       file://3.2.20/0083-ext4-don-t-trash-state-flags-in-EXT4_IOC_SETFLAGS.patch \
+       file://3.2.20/0084-ext4-don-t-set-i_flags-in-EXT4_IOC_SETFLAGS.patch \
+       file://3.2.20/0085-ext4-fix-the-free-blocks-calculation-for-ext3-file-s.patch \
+       file://3.2.20/0086-Linux-3.2.20.patch \
+       file://3.2.21/0001-drm-i915-Mark-the-ringbuffers-as-being-in-the-GTT-do.patch \
+       file://3.2.21/0002-drm-i915-hold-forcewake-around-ring-hw-init.patch \
+       file://3.2.21/0003-drm-i915-Unpin-the-flip-target-if-we-fail-to-queue-t.patch \
+       file://3.2.21/0004-drm-i915-fix-up-ivb-plane-3-pageflips.patch \
+       file://3.2.21/0005-char-agp-add-another-Ironlake-host-bridge.patch \
+       file://3.2.21/0006-x86-uv-Fix-UV2-BAU-legacy-mode.patch \
+       file://3.2.21/0007-powerpc-Fix-kernel-panic-during-kernel-module-load.patch \
+       file://3.2.21/0008-drm-nouveau-determine-a-value-for-display_info.bpc-i.patch \
+       file://3.2.21/0009-drm-nouveau-default-to-8bpc-for-non-LVDS-panels-if-E.patch \
+       file://3.2.21/0010-drm-nouveau-disp-fix-dithering-not-being-enabled-on-.patch \
+       file://3.2.21/0011-fuse-fix-stat-call-on-32-bit-platforms.patch \
+       file://3.2.21/0012-x86-MCE-AMD-Make-APIC-LVT-thresholding-interrupt-opt.patch \
+       file://3.2.21/0013-x86-amd-Re-enable-CPU-topology-extensions-in-case-BI.patch \
+       file://3.2.21/0014-hwmon-fam15h_power-Increase-output-resolution.patch \
+       file://3.2.21/0015-sched-Fix-the-relax_domain_level-boot-parameter.patch \
+       file://3.2.21/0016-iwlwifi-don-t-mess-up-the-SCD-when-removing-a-key.patch \
+       file://3.2.21/0017-hwrng-atmel-rng-fix-race-condition-leading-to-repeat.patch \
+       file://3.2.21/0018-crypto-aesni-intel-fix-unaligned-cbc-decrypt-for-x86.patch \
+       file://3.2.21/0019-xen-setup-filter-APERFMPERF-cpuid-feature-out.patch \
+       file://3.2.21/0020-NFSv4.1-Fix-a-request-leak-on-the-back-channel.patch \
+       file://3.2.21/0021-can-c_can-fix-BUG-echo_skb-is-occupied-during-transm.patch \
+       file://3.2.21/0022-can-c_can-fix-an-interrupt-thrash-issue-with-c_can-d.patch \
+       file://3.2.21/0023-can-c_can-fix-race-condition-in-c_can_open.patch \
+       file://3.2.21/0024-ARM-i.MX53-Fix-PLL4-base-address.patch \
+       file://3.2.21/0025-usb-musb_gadget-fix-crash-caused-by-dangling-pointer.patch \
+       file://3.2.21/0026-mac80211-clean-up-remain-on-channel-on-interface-sto.patch \
+       file://3.2.21/0027-rt2x00-use-atomic-variable-for-seqno.patch \
+       file://3.2.21/0028-iwlwifi-disable-WoWLAN-if-CONFIG_PM_SLEEP.patch \
+       file://3.2.21/0029-ASoC-wm8994-Ensure-all-AIFnCLK-events-are-run-from-t.patch \
+       file://3.2.21/0030-ASoC-wm8994-Apply-volume-updates-with-clocks-enabled.patch \
+       file://3.2.21/0031-iwlwifi-unregister-LEDs-if-mac80211-registration-fai.patch \
+       file://3.2.21/0032-cfg80211-fix-interface-combinations-check.patch \
+       file://3.2.21/0033-mpt2sas-Fix-unsafe-using-smp_processor_id-in-preempt.patch \
+       file://3.2.21/0034-net-sierra_net-device-IDs-for-Aircard-320U.patch \
+       file://3.2.21/0035-ARM-imx6-exit-coherency-when-shutting-down-a-cpu.patch \
+       file://3.2.21/0036-ARM-i.MX-imx21ads-Fix-overlapping-static-i-o-mapping.patch \
+       file://3.2.21/0037-NFSv4-Fix-unnecessary-delegation-returns-in-nfs4_do_.patch \
+       file://3.2.21/0038-iwlwifi-use-correct-supported-firmware-for-6035-and-.patch \
+       file://3.2.21/0039-iwlwifi-disable-the-buggy-chain-extension-feature-in.patch \
+       file://3.2.21/0040-ALSA-hda-Add-codec-no_jack_detect-flag.patch \
+       file://3.2.21/0041-ALSA-hda-add-support-for-Uniwill-ECS-M31EI-notebook.patch \
+       file://3.2.21/0042-ALSA-hda-Suppress-auto-mute-feature-on-some-machines.patch \
+       file://3.2.21/0043-ALSA-hda-Add-another-jack-detection-suppression-for-.patch \
+       file://3.2.21/0044-ALSA-HDA-Pin-fixup-for-Zotac-Z68-motherboard.patch \
+       file://3.2.21/0045-usb-cdc-wdm-Add-device-id-for-Huawei-3G-LTE-modems.patch \
+       file://3.2.21/0046-USB-qcserial-Add-Sierra-Wireless-device-IDs.patch \
+       file://3.2.21/0047-USB-ftdi-sio-Add-support-for-RT-Systems-USB-RTS01-se.patch \
+       file://3.2.21/0048-USB-serial-cp210x-add-Optris-MS-Pro-usb-id.patch \
+       file://3.2.21/0049-USB-serial-sierra-Add-support-for-Sierra-Wireless-Ai.patch \
+       file://3.2.21/0050-USB-option-Updated-Huawei-K4605-has-better-id.patch \
+       file://3.2.21/0051-USB-mct_u232-Fix-incorrect-TIOCMSET-return.patch \
+       file://3.2.21/0052-USB-option-fix-port-data-abuse.patch \
+       file://3.2.21/0053-USB-option-fix-memory-leak.patch \
+       file://3.2.21/0054-USB-option-add-more-YUGA-device-ids.patch \
+       file://3.2.21/0055-target-Return-error-to-initiator-if-SET-TARGET-PORT-.patch \
+       file://3.2.21/0056-USB-add-NO_D3_DURING_SLEEP-flag-and-revert-151b61284.patch \
+       file://3.2.21/0057-USB-serial-Enforce-USB-driver-and-USB-serial-driver-.patch \
+       file://3.2.21/0058-xhci-Fix-invalid-loop-check-in-xhci_free_tt_info.patch \
+       file://3.2.21/0059-xhci-Don-t-free-endpoints-in-xhci_mem_cleanup.patch \
+       file://3.2.21/0060-xHCI-Increase-the-timeout-for-controller-save-restor.patch \
+       file://3.2.21/0061-usb-PS3-EHCI-QH-read-work-around.patch \
+       file://3.2.21/0062-USB-fix-PS3-EHCI-systems.patch \
+       file://3.2.21/0063-usb-cdc-acm-fix-devices-not-unthrottled-on-open.patch \
+       file://3.2.21/0064-USB-fix-gathering-of-interface-associations.patch \
+       file://3.2.21/0065-swap-fix-shmem-swapping-when-more-than-8-areas.patch \
+       file://3.2.21/0066-drm-radeon-add-some-additional-6xx-7xx-EG-register-i.patch \
+       file://3.2.21/0067-Linux-3.2.21.patch \
        file://led/0001-leds-heartbeat-stop-on-shutdown-reboot-or-panic.patch \
+       file://libertas/0001-USB-convert-drivers-net-to-use-module_usb_driver.patch \
+       file://libertas/0002-net-fix-assignment-of-0-1-to-bool-variables.patch \
+       file://libertas/0003-switch-debugfs-to-umode_t.patch \
+       file://libertas/0004-drivers-net-Remove-unnecessary-k.alloc-v.alloc-OOM-m.patch \
+       file://libertas/0005-libertas-remove-dump_survey-implementation.patch \
+       file://libertas/0006-wireless-libertas-remove-redundant-NULL-tests-before.patch \
+       file://libertas/0007-libertas-fix-signedness-bug-in-lbs_auth_to_authtype.patch \
+       file://libertas/0008-drivers-net-wireless-libertas-if_usb.c-add-missing-d.patch \
+       file://libertas/0009-libertas-Firmware-loading-simplifications.patch \
+       file://libertas/0010-libertas-harden-up-exit-paths.patch \
+       file://libertas/0011-libertas-add-asynchronous-firmware-loading-capabilit.patch \
+       file://libertas/0012-libertas-SDIO-convert-to-asynchronous-firmware-loadi.patch \
+       file://libertas/0013-libertas-USB-convert-to-asynchronous-firmware-loadin.patch \
+       file://libertas/0014-libertas-CS-convert-to-asynchronous-firmware-loading.patch \
+       file://libertas/0015-libertas-add-missing-include.patch \
+       file://libertas/0016-remove-debug-msgs-due-to-missing-in_interrupt.patch \
        \
        file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \
        \
@@ -1220,4 +1528,13 @@ PATCHES_OVER_PSP = " \
        file://beaglebone/0061-beaglebone-make-uart2-pinmux-match-the-uart0-pinmux.patch \
        file://beaglebone/0062-da8xx-fb-Rounding-FB-size-to-satisfy-SGX-buffer-requ.patch \
        file://beaglebone/0063-beaglebone-dvi-cape-audio-hacks.patch \
+       file://beaglebone/0064-beaglebone-always-execute-the-pin-free-checks.patch \
+       file://beaglebone/0065-ti_tscadc-switch-to-16x-averaging.patch \
+       file://beaglebone/0066-beaglebone-disable-OPP-for-275MHz-due-to-silicon-err.patch \
+       file://beaglebone/0067-video-da8xx-fb-Add-Newhaven-LCD-Panel-details.patch \
+       file://beaglebone/0068-beaglebone-add-support-for-the-4.3-lcd-cape-with-res.patch \
+       file://beaglebone/0069-beaglebone-add-support-for-LCD3-rev-A1.patch \
+       file://beaglebone/0070-beaglebone-fix-buttons-spidev-clash-when-using-mcasp.patch \
+       file://beaglebone/0071-beaglebone-fix-LCD3-led-key-overlap.patch \
+       file://beaglebone/0072-beaglebone-fix-audio-spi-clash.patch \
 "