]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blobdiff - recipes-misc/payload/beaglebone-getting-started.bb
beaglebone-getting-started: active bone101 webserver on boot
[glsdk/meta-ti-glsdk.git] / recipes-misc / payload / beaglebone-getting-started.bb
index 9744f0b35ac22bbd4b2940c7a85facbd79ae8a42..7fe5861301b63d9eced522c75bd3df7a986f0c0b 100644 (file)
@@ -1,19 +1,27 @@
 DESCRIPTION = "BeagleBone Getting Started Guide"
 
-PR = "r4"
+PR = "r9"
 
-inherit allarch
+inherit allarch systemd
 
 LICENSE = "GPLv2+ && MIT && PD && others"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=603591dea023c3c75b48e07cb47ce639"
 
-SRCREV = "e7e01f4c2009aac07d2d73f5214d430f00d805f5"
-SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git"
+SRCREV = "ee3af61403b087c2882ba539d3358ba25c5b8dc7"
+SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git \
+           file://bone101.service"
+
 S = "${WORKDIR}/git"
 
 do_install() {
        install -d ${D}${datadir}/${PN}
        cp -a ${S}/* ${D}${datadir}/${PN}
+
+       install -d ${D}${base_libdir}/systemd/system
+       install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system
 }
 
-FILES_${PN} += "${datadir}/${PN}"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "bone101.service"
+
+FILES_${PN} += "${datadir}/${PN} ${base_libdir}/systemd/system"