]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-ti33x-psp 3.2: silence useless omap4 hwmod warning
authorKoen Kooi <koen@dominion.thruhere.net>
Tue, 22 May 2012 06:06:24 +0000 (08:06 +0200)
committerDenys Dmytriyenko <denys@ti.com>
Tue, 29 May 2012 19:49:14 +0000 (15:49 -0400)
This fixes the last remaining debug print shown when booting with 'quiet'

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0044-omap-hwmod-silence-st_shift-error.patch [new file with mode: 0644]
recipes-kernel/linux/linux-ti33x-psp_3.2.bb

diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0044-omap-hwmod-silence-st_shift-error.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0044-omap-hwmod-silence-st_shift-error.patch
new file mode 100644 (file)
index 0000000..7991f0a
--- /dev/null
@@ -0,0 +1,33 @@
+From 4119ec2ea20b7ae4095049e9f192c751559fbb87 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 16 May 2012 17:57:31 +0200
+Subject: [PATCH] omap hwmod: silence st_shift error
+
+During boot the following error is shown:
+
+       [    0.545227] omap_hwmod: wkup_m3: wkup_m3: hwmod data error: OMAP4 does not support st_shift
+
+Since this PSP tree will never run on omap4 remove the print so people will stop getting scared by it.
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ arch/arm/mach-omap2/omap_hwmod.c |    3 ---
+ 1 files changed, 0 insertions(+), 3 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/omap_hwmod.c b/arch/arm/mach-omap2/omap_hwmod.c
+index bc14f9f..a050699 100644
+--- a/arch/arm/mach-omap2/omap_hwmod.c
++++ b/arch/arm/mach-omap2/omap_hwmod.c
+@@ -1343,9 +1343,6 @@ static int _deassert_hardreset(struct omap_hwmod *oh, const char *name)
+        * Note: cpu_is_omap34xx is true for am33xx device as well.
+        */
+       if (cpu_is_omap44xx() || cpu_is_am33xx()) {
+-              if (ohri.st_shift)
+-                      pr_err("omap_hwmod: %s: %s: hwmod data error: OMAP4 does not support st_shift\n",
+-                             oh->name, name);
+               ret = omap4_prminst_deassert_hardreset(ohri.rst_shift,
+                                 oh->clkdm->pwrdm.ptr->prcm_partition,
+                                 oh->clkdm->pwrdm.ptr->prcm_offs,
+-- 
+1.7.7.6
+
index 97c1cd03a4c2f5c67e377282ef26d7959f2a3010..0fe3d4f0e1fe1a2770b3fee2f3e2dcaea57a99da 100644 (file)
@@ -968,6 +968,7 @@ PATCHES_OVER_PSP = " \
        file://beaglebone/0039-ARM-OMAP-Mux-Fixed-debugfs-mux-output-always-reporti.patch \
        file://beaglebone/0040-beaglebone-export-SPI2-as-spidev-when-no-capes-are-u.patch \
     file://beaglebone/0043-st7735fb-Working-WIP-changes-to-make-DMA-safe-and-ad.patch \
+       file://beaglebone/0044-omap-hwmod-silence-st_shift-error.patch \
        file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \
        file://beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch \
 "