]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
TI recipes: only use PACKAGE_ARCH = "${MACHINE_ARCH}" where needed
authorKoen Kooi <koen@dominion.thruhere.net>
Wed, 10 Aug 2011 06:38:18 +0000 (08:38 +0200)
committerKoen Kooi <koen@dominion.thruhere.net>
Tue, 16 Aug 2011 07:46:08 +0000 (09:46 +0200)
With machine specific staging in OE-core the tools (xdc, dmai, etc) can drop the PACKAGE_ARCH munging.

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-ti/codec-engine/ti-codec-engine.inc
recipes-ti/codec-engine/ti-codecs-omap3530_4.00.00.00.bb
recipes-ti/dmai/ti-dmai.inc
recipes-ti/gstreamer-ti/gstreamer-ti.inc
recipes-ti/includes/ti-staging.inc
recipes-ti/local-power-manager/ti-local-power-manager.inc

index 18c8cf4047286365f93bc50e50fcb8e5afcdd560..fde181e79e10745fd7f3d5d04a25e016e969f02b 100644 (file)
@@ -186,6 +186,8 @@ do_install() {
         cp -pPrf ${S}/* ${D}${CE_INSTALL_DIR_RECIPE}
 }
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
 PACKAGES += "ti-codec-engine-examples"
 
 RDEPENDS_ti-codec-engine-examples                 = " ti-cmem-module"
index 0bacf91d05bac4c9ccf8fa1066a4ce31337c696d..ae218b1026daf35f38dc783aaa89a13a85065b40 100644 (file)
@@ -200,6 +200,7 @@ do_install() {
     cp -pPrf ${CODEC_SUITE_NAME}/* ${D}${CODEC_INSTALL_DIR_RECIPE}
 }
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 PACKAGES += "ti-codecs-omap3530-server"
 FILES_ti-codecs-omap3530-server = "${installdir}/ti-codecs-server/*"
index a84f303a148db67f6c34c59cc4696acef2dde848..8b536fc871ea4252faef39a8f62bc39814c024f1 100644 (file)
@@ -141,6 +141,8 @@ do_install () {
     cp -pPrf ${S}/* ${D}${DMAI_INSTALL_DIR_RECIPE}
 }
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
 PACKAGES += "ti-dmai-apps"
 FILES_ti-dmai-apps = "${installdir}/ti-dmai-apps/*"
 INSANE_SKIP_ti-dmai-apps = True
index ded16ce84219e0de084ebec53b944f210269fc27..422d8c7e80f67f2dcc63d3c653f586838dbfe5ac 100644 (file)
@@ -143,6 +143,8 @@ pkg_postinst_${PN} () {
        fi
 }
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
 INITSCRIPT_NAME = "gstti-init"
 INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ."
 
index 2bacd7a99dc93c5643b614729a3bb7aa6b4db5e7..48ee061c925a58a856dd59598500429034c9416a 100644 (file)
@@ -1,5 +1,3 @@
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
 PACKAGE_STRIP = "no"
 
 ALLOW_EMPTY_${PN} = "1"
index 7ccbf9977f9ad92f3777be7173056b2387e0fcb1..46ea86b745ccd1cfa080e42821b08df753435207 100644 (file)
@@ -109,6 +109,7 @@ do_install () {
     cp -pPrf ${S}/* ${D}${LPM_INSTALL_DIR_RECIPE}
 }
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
 PACKAGES += "ti-lpm-module"
 FILES_ti-lpm-module = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/*lpm*ko"
 RDEPENDS_ti-lpm-module += "ti-dsplink-module"