]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
u-boot_2010.12-psp03.21.00.04.sdk: Add latest u-boot recipe for am180x-evm
authorFranklin S. Cooper Jr <fcooper@ti.com>
Tue, 12 Feb 2013 01:04:40 +0000 (19:04 -0600)
committerDenys Dmytriyenko <denys@ti.com>
Tue, 12 Feb 2013 23:16:22 +0000 (18:16 -0500)
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-bsp/u-boot/u-boot-2010.12-psp03.21.00.04.sdk/am180x-evm/0001-da850evm-change-default-memory-to-not-limit-at-32MB.patch [new file with mode: 0644]
recipes-bsp/u-boot/u-boot_2010.12-psp03.21.00.04.sdk.bb [new file with mode: 0644]

diff --git a/recipes-bsp/u-boot/u-boot-2010.12-psp03.21.00.04.sdk/am180x-evm/0001-da850evm-change-default-memory-to-not-limit-at-32MB.patch b/recipes-bsp/u-boot/u-boot-2010.12-psp03.21.00.04.sdk/am180x-evm/0001-da850evm-change-default-memory-to-not-limit-at-32MB.patch
new file mode 100644 (file)
index 0000000..b19575b
--- /dev/null
@@ -0,0 +1,34 @@
+From df5c87c4e1be1670475eba1187301a2f7a7aca30 Mon Sep 17 00:00:00 2001
+From: Chase Maupin <Chase.Maupin@ti.com>
+Date: Wed, 22 Jun 2011 12:12:09 -0500
+Subject: [PATCH] da850evm: change default memory to not limit at 32MB
+
+* Change the default mem= option passed to the Linux kernel to
+  not limit the memory to 32MB.
+* This change is used by AM devices that do not need to reserve
+  space for the DSP image.  By removing the mem= option we get
+  access to all of the memory on the system.
+* Limiting the memory to 32MB causes out-of-memory errors
+  when running large applications such as web browsers
+
+Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
+---
+ include/configs/da850evm.h |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/include/configs/da850evm.h b/include/configs/da850evm.h
+index 4a1e0af..55badc9 100755
+--- a/include/configs/da850evm.h
++++ b/include/configs/da850evm.h
+@@ -184,7 +184,7 @@
+ #define CONFIG_CMDLINE_TAG
+ #define CONFIG_REVISION_TAG
+ #define CONFIG_SETUP_MEMORY_TAGS
+-#define CONFIG_BOOTARGS               "mem=32M console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw rootwait ip=off"
++#define CONFIG_BOOTARGS               "console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw rootwait ip=off"
+ #define CONFIG_BOOTCOMMAND    "if mmc rescan 0; then if fatload mmc 0 0xc0600000 boot.scr; then source 0xc0600000; else fatload mmc 0 0xc0700000 uImage; bootm c0700000; fi; else sf probe 0; sf read 0xc0700000 0x80000 0x220000; bootm 0xc0700000; fi"
+ #define CONFIG_BOOTDELAY      3
+-- 
+1.7.0.4
+
diff --git a/recipes-bsp/u-boot/u-boot_2010.12-psp03.21.00.04.sdk.bb b/recipes-bsp/u-boot/u-boot_2010.12-psp03.21.00.04.sdk.bb
new file mode 100644 (file)
index 0000000..7652521
--- /dev/null
@@ -0,0 +1,29 @@
+# Use the version of u-boot.inc in oe-core not the meta-ti version
+require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
+
+DESCRIPTION = "u-boot bootloader for DaVinci devices"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b"
+
+COMPATIBLE_MACHINE = "am180x-evm"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+PR = "r0"
+
+SRC_URI = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git;branch=${BRANCH}"
+
+# For the am180x we want to enable all the memory on the EVM, but for other
+# devices that use the DSP we do not want this change because that memory
+# is used for the DSP
+SRC_URI_append_am180x-evm = " file://0001-da850evm-change-default-memory-to-not-limit-at-32MB.patch"
+
+BRANCH = "03.21.00.03"
+
+# Use literal tags in SRCREV, when available, instead of commit IDs
+SRCREV = "v2010.12_DAVINCIPSP_03.21.00.04"
+
+S = "${WORKDIR}/git"
+
+UBOOT_SUFFIX = "bin"