]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
u-boot 2011.10rc: fatload does not set loadaddr, so be explicit
authorKoen Kooi <koen@dominion.thruhere.net>
Tue, 8 Nov 2011 14:11:32 +0000 (15:11 +0100)
committerKoen Kooi <koen@dominion.thruhere.net>
Tue, 8 Nov 2011 14:34:39 +0000 (15:34 +0100)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch
recipes-bsp/u-boot/u-boot_2011.10rc.bb

index ff18bed6fc779584c2f8fa31e562ad44022dea7c..126ff24a1514b7d66bd4943d1c6c443ddea76057 100644 (file)
@@ -31,7 +31,7 @@ index 56e36da..8c0fae2 100755
        "mmc_boot=run mmc_args; " \
                "run mmc_load_uimage; " \
 -              "bootm ${loadaddr}\0" \
-+              "bootm\0" \
++              "bootm 0x80007fc0\0" \
        "nand_boot=echo Booting from nand ...; " \
                "run nand_args; " \
                "nand read.i ${loadaddr} ${nand_src_addr} ${nand_img_siz}; " \
@@ -40,7 +40,7 @@ index 56e36da..8c0fae2 100755
                "if run mmc_load_uimage; then " \
                        "run mmc_args;" \
 -                      "bootm ${loadaddr};" \
-+                      "bootm;" \
++                      "bootm 0x80007fc0;" \
                "fi;" \
        "fi;" \
        "run nand_boot;" \
index 983a1878c9ca281edc6eb3809066f29cd744b0f3..1065e53ab1a105b5bc68df386f462d02e9093d40 100644 (file)
@@ -4,7 +4,7 @@ require u-boot.inc
 COMPATIBLE_MACHINE = "(ti33x)"
 DEFAULT_PREFERENCE_ti33x = "99"
 PV = "2011.09+git"
-PR = "r22"
+PR = "r23"
 
 # SPL build
 UBOOT_BINARY = "u-boot.img"