]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
matrix-gui-common: update SRCREV and add device support
authorChase Maupin <chasemaupin03@gmail.com>
Wed, 16 Mar 2011 16:27:04 +0000 (11:27 -0500)
committerKoen Kooi <koen@dominion.thruhere.net>
Wed, 16 Mar 2011 17:49:28 +0000 (18:49 +0100)
* Update the SRCREV used for the matrix-gui-common_1.4 package.
* Add support for svg image formats
* Add support for the dm368-evm machine type

Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-bsp/ti/matrix-gui-common.inc
recipes-bsp/ti/matrix-gui-common_1.4.bb

index 58f41d01261b41dc19301922d26d7300429aaa5e..b1c9fb80ea45464acb7e557746416c22671414db 100644 (file)
@@ -6,11 +6,12 @@ LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=37;md5=a802a01a3a58f2ebb
 SECTION = "multimedia"
 PRIORITY = "optional"
 
 SECTION = "multimedia"
 PRIORITY = "optional"
 
-INC_PR = "r6"
+INC_PR = "r7"
 
 COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x)"
 
 
 COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x)"
 
-PLATFORM_dm365 = "dm365"
+PLATFORM_dm365-evm = "dm365"
+PLATFORM_dm368-evm = "dm368"
 PLATFORM_omapl138 = "omapl138"
 PLATFORM_omap3evm = "omap3530"
 PLATFORM_dm37x-evm = "dm3730"
 PLATFORM_omapl138 = "omapl138"
 PLATFORM_omap3evm = "omap3530"
 PLATFORM_dm37x-evm = "dm3730"
@@ -36,7 +37,7 @@ do_install() {
     install -m 0644 ${S}/${PLATFORM}/html/* ${D}/${datadir}/matrix/html
     install -d ${D}/${datadir}/matrix/images
     install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
     install -m 0644 ${S}/${PLATFORM}/html/* ${D}/${datadir}/matrix/html
     install -d ${D}/${datadir}/matrix/images
     install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
-
+    install -m 0644 ${S}/images/*.svg ${D}/${datadir}/matrix/images/
 }
 
 FILES_${PN} += "${datadir}/matrix/*"
 }
 
 FILES_${PN} += "${datadir}/matrix/*"
index c578a47b373dd0dbf76536fe231bed2b63eba736..609a16ae389563a53e2db184acc8cf2f553e6e28 100644 (file)
@@ -4,5 +4,5 @@ require matrix-gui-common.inc
 # prebuilt version in the repository.
 RRECOMMENDS_${PN} = "am-sysinfo"
 
 # prebuilt version in the repository.
 RRECOMMENDS_${PN} = "am-sysinfo"
 
-SRCREV = "192"
-PR = "${INC_PR}.0"
+SRCREV = "222"
+PR = "${INC_PR}.6"