]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
u-boot 2011.10rc: Read EEPROM header correctly for BeagleBone board detection
authorJoel A Fernandes <joelagnel@ti.com>
Fri, 21 Oct 2011 14:31:32 +0000 (09:31 -0500)
committerKoen Kooi <koen@dominion.thruhere.net>
Fri, 21 Oct 2011 16:57:36 +0000 (18:57 +0200)
This patch fixes the case where the EEPROM is programmed but we still use the
fall back case to detect the bone board. Now that EEPROMs are programmed, we should
correctly detect the bone board instead of relying on fall back to bone mode.

PR bumped

Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch [new file with mode: 0644]
recipes-bsp/u-boot/u-boot_2011.10rc.bb

diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch
new file mode 100644 (file)
index 0000000..ef901a9
--- /dev/null
@@ -0,0 +1,28 @@
+From 186250ee6abca3f080b5321504a1c5881ffbf7c6 Mon Sep 17 00:00:00 2001
+From: Joel A Fernandes <joelagnel@ti.com>
+Date: Thu, 20 Oct 2011 19:46:53 -0500
+Subject: [PATCH] am335x-evm: Read name field in EEPROM header for BeagleBoard bone detection
+
+Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
+---
+ board/ti/am335x/evm.c |    4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c
+index 37e348f..b63dcbe 100755
+--- a/board/ti/am335x/evm.c
++++ b/board/ti/am335x/evm.c
+@@ -501,6 +501,10 @@ int board_init(void)
+               detect_daughter_board_profile();
+       } else if (!strncmp("SKU#03", header.config, 6)) {
+               board_id = IPP_BOARD;
++      } else if (!strncmp("A335BONE", header.name, 8)) {
++              board_id = BONE_BOARD;
++              profile = 1;    /* profile 0 is internally considered as 1 */
++              daughter_board_connected = 0;
+       } else {
+               printf("Did not find a recognized configuration, "
+                       "assuming BeagleBone\n");
+-- 
+1.7.1
+
index 0bd39d3735f0d9a3f17c23a97db9e306369afb8b..ca7b670abd0fba97a51de6959561b7523ce042af 100644 (file)
@@ -4,7 +4,7 @@ require u-boot.inc
 COMPATIBLE_MACHINE = "(ti33x)"
 DEFAULT_PREFERENCE_ti33x = "99"
 PV = "2011.09+git"
-PR = "r14"
+PR = "r15"
 
 # SPL build
 UBOOT_BINARY = "u-boot.img"
@@ -18,6 +18,7 @@ SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;br
            file://2011.09git/0001-mach-types-Add-new-beaglebone-machine-type.patch \
            file://2011.09git/0003-am335x_evm-single-byte-address-EEPROM-for-board-iden.patch \
            file://2011.09git/0004-am335x-evm-fall-back-to-bone-if-header.config-is-emp.patch \
+           file://2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch \
           "
 
 SRCREV = "9158d7f37d596b867039345cb2e3f8f18f54fe46"