]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
beaglebone-capes: use backlight hack for all LCD4 variants
authorKoen Kooi <koen@dominion.thruhere.net>
Thu, 28 Jun 2012 09:53:55 +0000 (11:53 +0200)
committerDenys Dmytriyenko <denys@ti.com>
Thu, 26 Jul 2012 00:25:01 +0000 (20:25 -0400)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-ti/beagleboard/beaglebone-capes.bb
recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh
recipes-ti/beagleboard/beaglebone-capes/cape.sh

index b463a893640ac86813fa8c69046de0ca1f04fac6..ae9132ec1c881122571bdf75fa73137739ef5ede 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Userspace setup for beaglebone capes"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
 
-PR = "r3"
+PR = "r4"
 
 inherit allarch
 
index 49500176a0a8489381a50ac4d674b55a656f1e1c..222a010d25e7a4302f88acbc02c41f0d0b2e4c2a 100755 (executable)
@@ -5,8 +5,8 @@ for eeprom in /sys/bus/i2c/devices/3-005*/eeprom ; do
                "BB-BONE-LCD3-01.")
                                echo "Turning off backlight for LCD3 cape"
                                i2cset -f -y 1 0x24 0x07 0x00;;
-               "BB-BONE-LCD4-01.")
-                               echo "Turning off backlight for LCD3 cape"
+               "BB-BONE-LCD4"*)
+                               echo "Turning off backlight for LCD4 cape"
                                i2cset -f -y 1 0x24 0x07 0x00;;
                *)
                                echo "unknown cape: $PARTNUMBER";;
index 566cdf5f1b8e5f100c2d3cf4b892083dd0e7f758..c279349d7e7489baf4544b8bc9e04d389836cef1 100755 (executable)
@@ -6,7 +6,7 @@ for eeprom in /sys/bus/i2c/devices/3-005*/eeprom ; do
                                echo "Turning on backlight for LCD3 cape"
                                i2cset -f -y 1 0x24 0x07 0x09
                                i2cset -f -y 1 0x24 0x08 0x60;;
-               "BB-BONE-LCD4-01.")
+               "BB-BONE-LCD4"*)
                                echo "Turning on backlight for LCD4 cape"
                                i2cset -f -y 1 0x24 0x07 0x09
                                i2cset -f -y 1 0x24 0x08 0x60;;