]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-ti-staging: make cm3 firmware a run-time dependency
authorChase Maupin <Chase.Maupin@ti.com>
Thu, 18 Apr 2013 17:40:21 +0000 (12:40 -0500)
committerDenys Dmytriyenko <denys@ti.com>
Thu, 18 Apr 2013 19:44:11 +0000 (15:44 -0400)
* Make the am33x-cm3 firmware a run-time dependency instead of
  build time since it is no longer required at build time.

Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-kernel/linux/linux-ti-staging_3.8.bb

index 77d8e8ae04896d4bb5583a86cc9965508da34c99..6cbc2df7c13c0c805830566963d7c226a1d71907 100644 (file)
@@ -24,9 +24,9 @@ do_deploy_append() {
 require recipes-kernel/linux/linux-dtb.inc
 require recipes-kernel/linux/setup-defconfig.inc
 
-# Stage the power management firmware before building the kernel
-# for ti33x SOC_FAMILY devices
-DEPENDS_ti33x += "am33x-cm3"
+# Add a run-time dependency for the PM firmware to be installed
+# on the target file system.
+RDEPENDS_ti33x += "am33x-cm3"
 
 # Default is to package all dts files for ti33x devices unless building
 # for the specific beaglebone machine.
@@ -44,16 +44,8 @@ SRCREV = "881dfafeae47da3a8f5ff8c791753e4b4df8065b"
 PV = "3.8.5"
 
 # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
-MACHINE_KERNEL_PR_append = "d+gitr${SRCPV}"
+MACHINE_KERNEL_PR_append = "e+gitr${SRCPV}"
 
 SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
            file://defconfig \
           "
-
-# Copy the am33x-cm3 firmware if it is available for ti33x SOC_FAMILY devices
-do_compile_prepend_ti33x() {
-    if [ -e "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" ]
-    then
-        cp "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" "${S}/firmware"
-    fi
-}