]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-omap4: sync with OE
authorKoen Kooi <koen@dominion.thruhere.net>
Mon, 24 Jan 2011 19:29:56 +0000 (20:29 +0100)
committerKoen Kooi <koen@dominion.thruhere.net>
Mon, 24 Jan 2011 19:29:56 +0000 (20:29 +0100)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-bsp/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch [new file with mode: 0644]
recipes-bsp/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch [new file with mode: 0644]
recipes-bsp/linux/linux-omap4_2.6.35.3.bb

diff --git a/recipes-bsp/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch b/recipes-bsp/linux/linux-omap4/0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch
new file mode 100644 (file)
index 0000000..e83a3e2
--- /dev/null
@@ -0,0 +1,38 @@
+From 7699704e011db864c56f333bce9936a36522fb79 Mon Sep 17 00:00:00 2001
+From: Tim Gardner <tim.gardner@canonical.com>
+Date: Thu, 9 Dec 2010 08:16:52 -0700
+Subject: [PATCH 1/2] UBUNTU: [Config] Fix FTBS caused by new binutils
+
+New assemblers need -march=armv7-a+sec on command line or
+.arch_extension sec inline to enable use of the smc instruction.
+
+This patch uses as-instr to check the latter to conditionally
+enable the former in AFLAGS for files that use smc.
+
+Checked on both old and new binutils to verify that it does
+not break old versions.
+
+Signed-off-by: John Rigby <john.rigby@linaro.org>
+Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
+---
+ arch/arm/mach-omap2/Makefile |    4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/Makefile b/arch/arm/mach-omap2/Makefile
+index 75251b4..0241b4d 100644
+--- a/arch/arm/mach-omap2/Makefile
++++ b/arch/arm/mach-omap2/Makefile
+@@ -29,7 +29,9 @@ obj-$(CONFIG_HOTPLUG_CPU)            += omap-hotplug.o
+ obj-$(CONFIG_ARCH_OMAP4)              += omap44xx-smc.o omap4-common.o \
+                                          omap4-wakeupgen.o
+-AFLAGS_omap44xx-smc.o                 :=-Wa,-march=armv7-a
++plus_sec := $(call as-instr,.arch_extension sec,+sec)
++AFLAGS_omap-headsmp.o                  :=-Wa,-march=armv7-a$(plus_sec)
++AFLAGS_omap44xx-smc.o                  :=-Wa,-march=armv7-a$(plus_sec)
+ # Functions loaded to SRAM
+ obj-$(CONFIG_ARCH_OMAP2420)           += sram242x.o
+-- 
+1.7.0.2
+
diff --git a/recipes-bsp/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch b/recipes-bsp/linux/linux-omap4/0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch
new file mode 100644 (file)
index 0000000..ea16ab1
--- /dev/null
@@ -0,0 +1,26 @@
+From da58d36fb6b13899249bf1efbf25f7385d048bb3 Mon Sep 17 00:00:00 2001
+From: Tim Gardner <tim.gardner@canonical.com>
+Date: Tue, 14 Dec 2010 06:56:34 -0700
+Subject: [PATCH 2/2] Add AFLAGS for sleep44xx to fix FTBS
+
+Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
+---
+ arch/arm/mach-omap2/Makefile |    2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/Makefile b/arch/arm/mach-omap2/Makefile
+index 0241b4d..865a3e2 100644
+--- a/arch/arm/mach-omap2/Makefile
++++ b/arch/arm/mach-omap2/Makefile
+@@ -59,6 +59,8 @@ obj-$(CONFIG_ARCH_OMAP4)             += pm44xx.o pm_bus.o cpuidle44xx.o \
+                                          omap4-mpuss-lowpower.o sleep44xx.o \
+                                          voltage.o opp44xx_data.o
++AFLAGS_sleep44xx.o                  :=-Wa,-march=armv7-a$(plus_sec)
++
+ obj-$(CONFIG_PM_DEBUG)                        += pm-debug.o
+ obj-$(CONFIG_OMAP_SMARTREFLEX)          += sr_device.o smartreflex.o
+ obj-$(CONFIG_OMAP_SMARTREFLEX_CLASS3) += smartreflex-class3.o
+-- 
+1.7.0.2
+
index 4db0b284eee355aae6581bd2701b5d3d29d5baf2..050255443eddc0cbbd4ff16bc97b45fdeb9827ba 100644 (file)
@@ -4,7 +4,7 @@ require multi-kernel.inc
 
 CORTEXA8FIXUP = "no"
 
-SRCREV = "35528f5b0481485654a6577306f7a80d9e6a5cf5"
+SRCREV = "ti-ubuntu-2.6.35-980.1release13"
 
 SRC_URI = "git://dev.omapzoom.org/pub/scm/integration/kernel-ubuntu.git;protocol=git;branch=ti-ubuntu-L24.11 \
            file://0001-tiler-avoid-lock-ups-due-to-unmapped-DMM-entries.patch \
@@ -15,6 +15,8 @@ SRC_URI = "git://dev.omapzoom.org/pub/scm/integration/kernel-ubuntu.git;protocol
            file://0006-ARM-Add-option-to-allow-userspace-access-to-performa.patch \
            file://0007-OMAP4-do-not-force-select-options-which-are-not-requ.patch \
            file://0008-omap4-pandaboard-add-support-for-DVI-output.patch \
+          file://0001-UBUNTU-Config-Fix-FTBS-caused-by-new-binutils.patch \
+          file://0002-Add-AFLAGS-for-sleep44xx-to-fix-FTBS.patch \
            file://defconfig"
 
 S = "${WORKDIR}/git"