summary | shortlog | log | commit | commitdiff | tree
raw | patch | inline | side by side (parent: 0be62d6)
raw | patch | inline | side by side (parent: 0be62d6)
author | Koen Kooi <koen@dominion.thruhere.net> | |
Fri, 4 May 2012 09:02:11 +0000 (11:02 +0200) | ||
committer | Denys Dmytriyenko <denys@ti.com> | |
Thu, 10 May 2012 19:31:34 +0000 (15:31 -0400) |
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0031-omap2-irq-process-all-4-irq-banks-for-am335x.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0031-omap2-irq-process-all-4-irq-banks-for-am335x.patch
--- /dev/null
@@ -0,0 +1,26 @@
+From d5f1df216fb51e1edc3e18b6b4c6d382141cf8dd Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 2 May 2012 13:51:57 +0200
+Subject: [PATCH 31/32] omap2+ irq: process all 4 irq banks for am335x
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ arch/arm/mach-omap2/irq.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/arch/arm/mach-omap2/irq.c b/arch/arm/mach-omap2/irq.c
+index 1fef061..419b1a1 100644
+--- a/arch/arm/mach-omap2/irq.c
++++ b/arch/arm/mach-omap2/irq.c
+@@ -212,7 +212,7 @@ static inline void omap_intc_handle_irq(void __iomem *base_addr, struct pt_regs
+ goto out;
+
+ irqnr = readl_relaxed(base_addr + 0xd8);
+-#ifdef CONFIG_SOC_OMAPTI816X
++#if defined(CONFIG_SOC_OMAPTI816X) || defined(CONFIG_SOC_OMAPAM33XX)
+ if (irqnr)
+ goto out;
+ irqnr = readl_relaxed(base_addr + 0xf8);
+--
+1.7.9.5
+
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0032-omap2-irqs.h-increase-number-or-irq-banks.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0032-omap2-irqs.h-increase-number-or-irq-banks.patch
--- /dev/null
@@ -0,0 +1,28 @@
+From c551ce3e274195934304b16cc109204a987c4295 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 2 May 2012 13:56:12 +0200
+Subject: [PATCH 32/32] omap2+ irqs.h: increase number or irq banks
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ arch/arm/plat-omap/include/plat/irqs.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/arch/arm/plat-omap/include/plat/irqs.h b/arch/arm/plat-omap/include/plat/irqs.h
+index ce6a73c..cc15272 100644
+--- a/arch/arm/plat-omap/include/plat/irqs.h
++++ b/arch/arm/plat-omap/include/plat/irqs.h
+@@ -434,8 +434,8 @@
+
+ #define OMAP_IRQ_BIT(irq) (1 << ((irq) % 32))
+
+-#define INTCPS_NR_MIR_REGS 3
+-#define INTCPS_NR_IRQS 96
++#define INTCPS_NR_MIR_REGS 4
++#define INTCPS_NR_IRQS 128
+
+ #include <mach/hardware.h>
+
+--
+1.7.9.5
+
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
index f560a1d1a02b8940ac86357e2596d4488c8de86b..35d1b2684ae9f3ea24c569095d479a5d819bc173 100644 (file)
MULTI_CONFIG_BASE_SUFFIX = ""
BRANCH = "v3.2-staging"
-SRCREV = "e8004dad869568692ca2a45c04e8464ce48cc4d7"
-MACHINE_KERNEL_PR_append = "d+gitr${SRCREV}"
+SRCREV = "0d0567b6c1a61a374120b985559768077c511a6d"
+MACHINE_KERNEL_PR_append = "e+gitr${SRCREV}"
COMPATIBLE_MACHINE = "(ti33x)"
file://beaglebone/0028-beaglebone-fix-ehrpwm-backlight.patch \
file://beaglebone/0029-beaglebone-also-report-cape-revision.patch \
file://beaglebone/0030-beaglebone-don-t-compare-undefined-characters-it-mak.patch \
+ file://beaglebone/0031-omap2-irq-process-all-4-irq-banks-for-am335x.patch \
+ file://beaglebone/0032-omap2-irqs.h-increase-number-or-irq-banks.patch \
"
+