]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-omap 2.6.39: fix rootfs over nfs
authorEnrico Butera <ebutera@users.berlios.de>
Wed, 20 Jul 2011 09:33:46 +0000 (11:33 +0200)
committerKoen Kooi <koen@dominion.thruhere.net>
Wed, 20 Jul 2011 10:49:50 +0000 (12:49 +0200)
Import patch from [1] to fix mounting the rootfs over nfs.

[1]: http://git.linux-nfs.org/?p=trondmy/nfs-2.6.git;a=commit;h=4251c94833aa516c1fc7a0f8f504a26eadd4b91e

Tested-by: Enrico Butera <ebutera@users.berlios.de>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-kernel/linux/linux-omap-2.6.39/net/0001-NFS-Revert-NFSROOT-default-mount-options.patch [new file with mode: 0644]
recipes-kernel/linux/linux-omap_2.6.39.bb

diff --git a/recipes-kernel/linux/linux-omap-2.6.39/net/0001-NFS-Revert-NFSROOT-default-mount-options.patch b/recipes-kernel/linux/linux-omap-2.6.39/net/0001-NFS-Revert-NFSROOT-default-mount-options.patch
new file mode 100644 (file)
index 0000000..617698d
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/fs/nfs/nfsroot.c b/fs/nfs/nfsroot.c
+index c541093..c4744e1 100644
+--- a/fs/nfs/nfsroot.c
++++ b/fs/nfs/nfsroot.c
+@@ -87,7 +87,7 @@
+ #define NFS_ROOT              "/tftpboot/%s"
+ /* Default NFSROOT mount options. */
+-#define NFS_DEF_OPTIONS               "udp"
++#define NFS_DEF_OPTIONS               "vers=2,udp,rsize=4096,wsize=4096"
+ /* Parameters passed from the kernel command line */
+ static char nfs_root_parms[256] __initdata = "";
index 10a2426cdb673e419bb71176dd29667ad0c3f814..c92846d77263818b6c02a3608928c3e17aaa6cd2 100644 (file)
@@ -7,7 +7,7 @@ COMPATIBLE_MACHINE = "(beagleboard)"
 
 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
 SRCREV_pn-${PN} = "v2.6.39"
 
 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
 SRCREV_pn-${PN} = "v2.6.39"
-MACHINE_KERNEL_PR_append = "m"
+MACHINE_KERNEL_PR_append = "n"
 
 FILESPATHPKG_prepend = "linux-omap-2.6.39:"
 
 
 FILESPATHPKG_prepend = "linux-omap-2.6.39:"
 
@@ -113,6 +113,8 @@ SRC_URI_append = " \
            file://mfd/0013-MFD-TWL4030-optimizing-resource-configuration.patch \
            \
            file://musb/0001-usb-musb-Enable-DMA-mode1-RX-for-USB-Mass-Storage.patch \
            file://mfd/0013-MFD-TWL4030-optimizing-resource-configuration.patch \
            \
            file://musb/0001-usb-musb-Enable-DMA-mode1-RX-for-USB-Mass-Storage.patch \
+           \
+           file://net/0001-NFS-Revert-NFSROOT-default-mount-options.patch \
            "
 
 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
            "
 
 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \