]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-ti-staging: use setup-defconfig
authorChase Maupin <Chase.Maupin@ti.com>
Mon, 11 Mar 2013 20:03:32 +0000 (15:03 -0500)
committerDenys Dmytriyenko <denys@ti.com>
Mon, 11 Mar 2013 21:17:10 +0000 (17:17 -0400)
* Use the setup-defconfig.inc functionality to specify the in
  kernel tree defconfig file to use rather than hard coding it
  in the do_configure step.
* This is to make it easier to modify which configs are use by
  other layers as well as supporting additional machines which
  may not use omap2plus_defconfig as needed.

Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-kernel/linux/linux-ti-staging/defconfig [new file with mode: 0644]
recipes-kernel/linux/linux-ti-staging_git.bb

diff --git a/recipes-kernel/linux/linux-ti-staging/defconfig b/recipes-kernel/linux/linux-ti-staging/defconfig
new file mode 100644 (file)
index 0000000..926b35a
--- /dev/null
@@ -0,0 +1 @@
+use-kernel-config=omap2plus_defconfig
index 8cc7206af9aaf790ed5699bae43d008afa36fbc5..2581409916ae31b318856f6ba8a2605018574516 100644 (file)
@@ -6,6 +6,7 @@ KERNEL_IMAGETYPE = "uImage"
 
 inherit kernel
 require recipes-kernel/linux/linux-dtb.inc
+require recipes-kernel/linux/setup-defconfig.inc
 
 # Stage the power management firmware before building the kernel
 DEPENDS += "am33x-cm3"
@@ -23,17 +24,11 @@ SRCREV = "d26595a42220789b81a9d243e2fc0837c7776360"
 PV = "3.8.2"
 
 # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
-MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
+MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}"
 
-SRC_URI = "git://gitorious.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH}"
-
-do_setup_defconfig() {
-        :
-}
-
-do_configure() {
-    oe_runmake omap2plus_defconfig
-}
+SRC_URI = "git://gitorious.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
+           file://defconfig \
+          "
 
 # Copy the am33x-cm3 firmware if it is available
 do_compile_prepend() {