]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
bonescript, beaglebone-getting-started: move bone101 startup to proper recipe
authorKoen Kooi <koen@dominion.thruhere.net>
Mon, 14 Nov 2011 14:08:50 +0000 (15:08 +0100)
committerKoen Kooi <koen@dominion.thruhere.net>
Mon, 14 Nov 2011 14:16:50 +0000 (15:16 +0100)
Also bump SRCREV

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-misc/payload/beaglebone-getting-started.bb
recipes-misc/payload/bonescript.bb
recipes-misc/payload/bonescript/bone101.service [moved from recipes-misc/payload/beaglebone-getting-started/bone101.service with 100% similarity]

index ea5b038a2be8d1d0b93614a6a10c0fa6ffdabcfe..81d8cedaf5b24de81716a89da8763305382bb66c 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "BeagleBone Getting Started Guide"
 
 DESCRIPTION = "BeagleBone Getting Started Guide"
 
-PR = "r11"
+PR = "r12"
 
 inherit allarch
 
 
 inherit allarch
 
@@ -8,20 +8,13 @@ LICENSE = "GPLv2+ && MIT && PD && others"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=603591dea023c3c75b48e07cb47ce639"
 
 SRCREV = "70ff0ec0e2d44de35824577ab7b6da443dcc0e9a"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=603591dea023c3c75b48e07cb47ce639"
 
 SRCREV = "70ff0ec0e2d44de35824577ab7b6da443dcc0e9a"
-SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git \
-           file://bone101.service"
+SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git"
 
 S = "${WORKDIR}/git"
 
 do_install() {
        install -d ${D}${datadir}/${PN}
        cp -a ${S}/* ${D}${datadir}/${PN}
 
 S = "${WORKDIR}/git"
 
 do_install() {
        install -d ${D}${datadir}/${PN}
        cp -a ${S}/* ${D}${datadir}/${PN}
-
-       install -d ${D}${base_libdir}/systemd/system
-       install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system
 }
 
 }
 
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "bone101.service"
-
-FILES_${PN} += "${datadir}/${PN} ${base_libdir}/systemd/system"
+FILES_${PN} += "${datadir}/${PN}"
index bbce02237a5e603de9172949cffd299b8eddbad8..d9e3b0188ec7d331f0964cf2015e8c143a86bc21 100644 (file)
@@ -1,16 +1,17 @@
 DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone"
 
 DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone"
 
-PR = "r6"
+PR = "r8"
 
 
-inherit allarch
+inherit allarch systemd
 
 # Ask Jason
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
 
 
 # Ask Jason
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
 
-SRCREV = "0b264f3144cb6385e33346dec02692d71844898d"
+SRCREV = "c6c5f3b013eea425d3f4ee64d58b993289d2530f"
 SRC_URI = "git://github.com/jadonk/bonescript.git \
            file://bonescript-git \
 SRC_URI = "git://github.com/jadonk/bonescript.git \
            file://bonescript-git \
+           file://file://bone101.service \
           "
 S = "${WORKDIR}/git"
 
           "
 S = "${WORKDIR}/git"
 
@@ -23,8 +24,14 @@ do_install() {
        install -d ${D}${localstatedir}/lib/cloud9/
        cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/
        cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/
        install -d ${D}${localstatedir}/lib/cloud9/
        cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/
        cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/
+
+       install -d ${D}${base_libdir}/systemd/system
+       install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system
 }
 
 }
 
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "bone101.service"
+
+FILES_${PN} += ""${localstatedir} ${base_libdir}/systemd/system"
 RDEPENDS_${PN} = "nodejs cloud9"
 RRECOMMENDS_${PN} = "git"
 RDEPENDS_${PN} = "nodejs cloud9"
 RRECOMMENDS_${PN} = "git"
-FILES_${PN} += "${localstatedir}"