]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-ti33x-psp 3.2: avoid gold linker for Thumb2 kernel
authorDenys Dmytriyenko <denys@ti.com>
Fri, 11 May 2012 01:55:15 +0000 (21:55 -0400)
committerDenys Dmytriyenko <denys@ti.com>
Fri, 11 May 2012 17:21:28 +0000 (13:21 -0400)
BeagleBone kernel is required to be built in Thumb2 mode for fast boot.
Gold linker is not yet perfect for this, giving an internal error:

| arm-linux-gnueabi-ld: internal error in thumb_branch_common, at .../binutils-cross-2.22-r6/binutils-2.22/gold/arm.cc:4149

While this fix can be put in generic linux.inc for all the kernels, it's
better to test the Gold linker out as much as possible and only disable it
for known issues, like this one (until it gets fixed, of course).

Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-kernel/linux/linux-ti33x-psp_3.2.bb

index d1dfaaf1600a7e553be04aede48ded63397d2e2e..0f44a950095c349025d29a858417499373f8b25d 100644 (file)
@@ -22,6 +22,8 @@ SRC_URI += "git://arago-project.org/git/projects/linux-am33x.git;protocol=http;b
 
 SRC_URI_append_beaglebone = " file://logo_linux_clut224.ppm"
 
+KERNEL_LDSUFFIX_beaglebone = "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', '.bfd', '', d)}"
+
 do_compile_prepend() {
        cp ${WORKDIR}/am335x-pm-firmware.bin ${S}/firmware/
 }