summary | shortlog | log | commit | commitdiff | tree
raw | patch | inline | side by side (parent: 682d21f)
raw | patch | inline | side by side (parent: 682d21f)
author | Koen Kooi <koen@dominion.thruhere.net> | |
Fri, 28 Jan 2011 20:01:29 +0000 (21:01 +0100) | ||
committer | Koen Kooi <koen@dominion.thruhere.net> | |
Fri, 28 Jan 2011 20:04:17 +0000 (21:04 +0100) |
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
diff --git a/recipes-bsp/x-load/x-load/0001-OMAP4-clocks-Enable-only-required-clks.patch b/recipes-bsp/x-load/x-load/0001-OMAP4-clocks-Enable-only-required-clks.patch
index 774f1e78ca59bb9a490c4be10beef9b0706768b6..6cec4ef8f9c2448e1f2f960a31438277119e63f0 100644 (file)
-From 94fee465a6d63b6f0551037fe14cec4410bb9af2 Mon Sep 17 00:00:00 2001
+From 7c5a2dd1e20702d220bd75910f7cfb6141230e5b Mon Sep 17 00:00:00 2001
From: Rajendra Nayak <rnayak@ti.com>
Date: Tue, 21 Dec 2010 11:55:01 -0200
Subject: [PATCH 1/5] OMAP4: clocks: Enable only required clks
1 files changed, 117 insertions(+), 108 deletions(-)
diff --git a/board/omap4430panda/clock.c b/board/omap4430panda/clock.c
-index 792e5d6..149fc85 100644
+index a83f1c6..b323885 100644
--- a/board/omap4430panda/clock.c
+++ b/board/omap4430panda/clock.c
@@ -552,71 +552,73 @@ static void enable_all_clocks(void)
diff --git a/recipes-bsp/x-load/x-load/0002-OMAP4-Select-DPLL-PER-Clock-as-source-for-SGX-FCLK.patch b/recipes-bsp/x-load/x-load/0002-OMAP4-Select-DPLL-PER-Clock-as-source-for-SGX-FCLK.patch
index ffcf8591afb3da6926aedfc7abfbfd1f95075210..8e62d2fdc7356fa44cd2671730e0bb5c79d76a5e 100644 (file)
-From fff093ab92c5dadd646130c38097dc167d2d0e1e Mon Sep 17 00:00:00 2001
+From 17028354b438883e98668803bf433d8a0bae12a1 Mon Sep 17 00:00:00 2001
From: Rajeev Kulkarni <rajeevk@ti.com>
Date: Tue, 26 Oct 2010 07:34:43 -0500
Subject: [PATCH 2/5] OMAP4: Select DPLL PER Clock as source for SGX FCLK
1 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/board/omap4430panda/clock.c b/board/omap4430panda/clock.c
-index 149fc85..0961f51 100644
+index b323885..4404cc5 100644
--- a/board/omap4430panda/clock.c
+++ b/board/omap4430panda/clock.c
@@ -772,6 +772,9 @@ static void enable_all_clocks(void)
diff --git a/recipes-bsp/x-load/x-load/0003-MUX-Configure-SYS_NIRQ2-pin-in-safe-mode.patch b/recipes-bsp/x-load/x-load/0003-MUX-Configure-SYS_NIRQ2-pin-in-safe-mode.patch
index 1475308f742134090cf8c59b3dc19695b8f480e4..7f9b767243d85dccbc968a515eea16e00eaf2566 100644 (file)
-From daaaf036f3336e01a83a13dd93b8030b00a0af50 Mon Sep 17 00:00:00 2001
+From 3421142b95238893a90032c3056123544c353752 Mon Sep 17 00:00:00 2001
From: Ricardo Salveti de Araujo <ricardo.salveti@canonical.com>
Date: Tue, 21 Dec 2010 12:03:50 -0200
Subject: [PATCH 3/5] MUX: Configure SYS_NIRQ2 pin in safe mode
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/board/omap4430panda/omap4430panda.c b/board/omap4430panda/omap4430panda.c
-index 5695733..814b2cb 100644
+index a91e2aa..f6f515b 100644
--- a/board/omap4430panda/omap4430panda.c
+++ b/board/omap4430panda/omap4430panda.c
@@ -910,7 +910,7 @@ int dram_init(void)
diff --git a/recipes-bsp/x-load/x-load/0004-OMAP4-clocks-Disable-slimbus-and-pad_clks.patch b/recipes-bsp/x-load/x-load/0004-OMAP4-clocks-Disable-slimbus-and-pad_clks.patch
index 9b6e2f9da28ba88f383f48464ee6010e1f1288fd..e3107121655e071a97ea266dc80a3885e03d59d8 100644 (file)
-From 4af562525c7779cd41ae9a68d56771407df558d7 Mon Sep 17 00:00:00 2001
+From 14a48e4b24aee2387f8e4cd3b480236451fe1294 Mon Sep 17 00:00:00 2001
From: Rajendra Nayak <rnayak@ti.com>
Date: Mon, 4 Oct 2010 18:49:18 +0530
Subject: [PATCH 4/5] OMAP4: clocks: Disable slimbus and pad_clks
1 files changed, 0 insertions(+), 3 deletions(-)
diff --git a/board/omap4430panda/clock.c b/board/omap4430panda/clock.c
-index 0961f51..c591a9f 100644
+index 4404cc5..e41f327 100644
--- a/board/omap4430panda/clock.c
+++ b/board/omap4430panda/clock.c
@@ -333,9 +333,6 @@ static void configure_abe_dpll(u32 clk_index)
diff --git a/recipes-bsp/x-load/x-load/0005-omap4-Make-1GHz-as-default-MPU-clock.patch b/recipes-bsp/x-load/x-load/0005-omap4-Make-1GHz-as-default-MPU-clock.patch
index 7c23f604b24c49615a539026f8695adc378d046b..3008e6da392ad4f7607201503fae174185ab026c 100644 (file)
-From ce1ae065d5eb875990f55ede0405e061e4d4b8d3 Mon Sep 17 00:00:00 2001
+From 76ebc9fdbfff91f226bc559706e3e7ece43ec30d Mon Sep 17 00:00:00 2001
From: Sebastien Jan <s-jan@ti.com>
Date: Wed, 22 Dec 2010 13:53:18 +0100
Subject: [PATCH 5/5] omap4: Make 1GHz as default MPU clock
Signed-off-by: Sebastien Jan <s-jan@ti.com>
Signed-off-by: Ricardo Salveti de Araujo <ricardo.salveti@canonical.com>
---
- Makefile | 8 ++++++++
+ Makefile | 9 +++++++++
include/configs/omap4430panda.h | 1 -
- 2 files changed, 8 insertions(+), 1 deletions(-)
+ 2 files changed, 9 insertions(+), 1 deletions(-)
diff --git a/Makefile b/Makefile
-index d134fdc..1c4fdd5 100644
+index fd85142..6258324 100644
--- a/Makefile
+++ b/Makefile
-@@ -170,6 +170,14 @@ omap3530beagle_config : unconfig
+@@ -235,6 +235,15 @@ igep0020_config : unconfig
#########################################################################
omap4430panda_config : unconfig
- @./mkconfig $(@:_config=) arm omap4 omap4430panda
+ @./mkconfig $(@:_config=) arm omap4 omap4430panda 1
++ @./mkconfig $(@:_config=) arm omap4 omap4430panda 1
+ @[ -n "$(findstring _MPU_600MHz,$@)" ] || \
+ { echo "#define CONFIG_MPU_1000 1" >> $(obj)include/config.h; \
+ echo "MPU at 1GHz revision.."; \
index 4ab0a34f226d6a1a4f5424969167074d6c7bf65a..5be261b7c8c45b79a02ebe359de245c3385df372 100644 (file)
#FILESPATHPKG_prepend = "x-load-git:x-load-git/${MACHINE}"
PV = "1.44+${PR}+gitr${SRCREV}"
-PR ="r17"
+PR ="r20"
PE = "1"
-SRCREV_pn-${PN} = "6f3a26101303051e0f91b6213735b68ce804e94e"
+SRCREV_pn-${PN} = "24b8b7f41a83540433024854736518876257672c"
SRC_URI = "git://gitorious.org/x-loader/x-loader.git;branch=master;protocol=git \
file://0001-OMAP4-clocks-Enable-only-required-clks.patch \
file://0002-OMAP4-Select-DPLL-PER-Clock-as-source-for-SGX-FCLK.patch \