summary | shortlog | log | commit | commitdiff | tree
raw | patch | inline | side by side (parent: d07130d)
raw | patch | inline | side by side (parent: d07130d)
author | Koen Kooi <koen@dominion.thruhere.net> | |
Sun, 9 Oct 2011 09:25:19 +0000 (11:25 +0200) | ||
committer | Koen Kooi <koen@dominion.thruhere.net> | |
Sun, 9 Oct 2011 09:25:19 +0000 (11:25 +0200) |
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch | patch | blob | history | |
recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch | [new file with mode: 0644] | patch | blob |
recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch | [new file with mode: 0644] | patch | blob |
recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch | [new file with mode: 0644] | patch | blob |
recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch | [new file with mode: 0644] | patch | blob |
recipes-bsp/u-boot/u-boot_2011.10rc.bb | patch | blob | history |
diff --git a/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch b/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch
index af7fae72a89e92da454f41427f8621b14ed33565..3f030565878ec120ec3636cf448d7f25eddfba57 100644 (file)
-From 5db18d5efdbdcd52ab33e28929a30f743a202bf8 Mon Sep 17 00:00:00 2001
+From 8bf8cbead1115e2a47b74f53b96272bbacad0df2 Mon Sep 17 00:00:00 2001
From: Koen Kooi <koen@dominion.thruhere.net>
Date: Fri, 7 Oct 2011 18:17:50 +0200
-Subject: [PATCH] am335x-evm: hack in ethernet rmii clock
+Subject: [PATCH 1/5] am335x-evm: hack in ethernet rmii clock
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
---
diff --git a/recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch b/recipes-bsp/u-boot/u-boot/0002-am335x_evm-reduced-bootdelay-to-0.patch
--- /dev/null
@@ -0,0 +1,35 @@
+From 8c7d293dcbf1bb53c4e8f26fc2553e99880978d1 Mon Sep 17 00:00:00 2001
+From: Jason Kridner <jdk@ti.com>
+Date: Sat, 8 Oct 2011 15:48:57 -0400
+Subject: [PATCH 2/5] am335x_evm: reduced bootdelay to 0
+
+---
+ include/configs/am335x_evm.h | 5 +----
+ 1 files changed, 1 insertions(+), 4 deletions(-)
+
+diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
+index 0f806aa..c5e608c 100755
+--- a/include/configs/am335x_evm.h
++++ b/include/configs/am335x_evm.h
+@@ -24,7 +24,7 @@
+ #define CONFIG_AM335X_HSMMC_INSTANCE 0 /* 0 - MMC0, 1 - MMC1 */
+
+ /* set to negative value for no autoboot */
+-#define CONFIG_BOOTDELAY 3
++#define CONFIG_BOOTDELAY 0
+
+ # if defined(CONFIG_SPI_BOOT)
+ # define CONFIG_SPI 1
+@@ -73,9 +73,6 @@
+ #define CONFIG_SETUP_MEMORY_TAGS 1
+ #define CONFIG_INITRD_TAG 1 /* Required for ramdisk support */
+
+-/* set to negative value for no autoboot */
+-#define CONFIG_BOOTDELAY 3
+-
+ #define CONFIG_MMC 1
+
+ #ifndef CONFIG_NOR_BOOT
+--
+1.6.6.1
+
diff --git a/recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch b/recipes-bsp/u-boot/u-boot/0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch
--- /dev/null
@@ -0,0 +1,34 @@
+From 9de8f53dea91169f3b8a9473ad2b5c9c0fdd0eb1 Mon Sep 17 00:00:00 2001
+From: Jason Kridner <jdk@ti.com>
+Date: Sat, 8 Oct 2011 16:22:53 -0400
+Subject: [PATCH 3/5] am335x_evm: boot kernel from ext2 filesystem
+
+---
+ include/configs/am335x_evm.h | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
+index c5e608c..a2e4564 100755
+--- a/include/configs/am335x_evm.h
++++ b/include/configs/am335x_evm.h
+@@ -112,7 +112,8 @@
+ "loadbootscript=fatload mmc 0 ${script_addr} boot.scr\0" \
+ "bootscript= echo Running bootscript from MMC/SD to set the ENV...; " \
+ "source ${script_addr}\0" \
+- "mmc_load_uimage=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
++ "mmc_load_uimage_fat=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
++ "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \
+ "bootargs_defaults=setenv bootargs " \
+ "console=${console}\0 " \
+ "mmc_args=run bootargs_defaults;" \
+@@ -403,6 +404,7 @@
+ # define CONFIG_CMD_MMC 1
+ # define CONFIG_DOS_PARTITION 1
+ # define CONFIG_CMD_FAT 1
++# define CONFIG_CMD_EXT2 1
+ #endif
+
+ /* Unsupported features */
+--
+1.6.6.1
+
diff --git a/recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch b/recipes-bsp/u-boot/u-boot/0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch
--- /dev/null
@@ -0,0 +1,64 @@
+From abf7185e16b2b96db7aa06af56bd84836eff92f6 Mon Sep 17 00:00:00 2001
+From: Jason Kridner <jdk@ti.com>
+Date: Sat, 8 Oct 2011 16:20:50 -0400
+Subject: [PATCH 4/5] am335x_evm: read uEnv.txt instead of boot.scr
+
+Also restructured the BOOTCMD flow a bit to avoid pointless if/then depth.
+
+I'm considering to respect both boot.scr and uEnv.txt.
+---
+ include/configs/am335x_evm.h | 30 ++++++++++++++++++------------
+ 1 files changed, 18 insertions(+), 12 deletions(-)
+
+diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
+index a2e4564..e157fd7 100755
+--- a/include/configs/am335x_evm.h
++++ b/include/configs/am335x_evm.h
+@@ -112,6 +112,10 @@
+ "loadbootscript=fatload mmc 0 ${script_addr} boot.scr\0" \
+ "bootscript= echo Running bootscript from MMC/SD to set the ENV...; " \
+ "source ${script_addr}\0" \
++ "bootenv=uEnv.txt\0" \
++ "loadbootenv=fatload mmc 0 ${loadaddr} ${bootenv}\0" \
++ "importbootenv=echo Importing environment from mmc ...; " \
++ "env import -t $loadaddr $filesize\0" \
+ "mmc_load_uimage_fat=fatload mmc 0 ${loadaddr} ${bootfile}\0" \
+ "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \
+ "bootargs_defaults=setenv bootargs " \
+@@ -161,19 +165,21 @@
+ "bootm ${loadaddr}\0" \
+
+ #define CONFIG_BOOTCOMMAND \
+- "mw.l 0x44e10650 0x05 ; if mmc rescan; then " \
+- "if run loadbootscript; then " \
+- "run bootscript; " \
+- "else " \
+- "if run mmc_load_uimage; then " \
+- "run mmc_boot; " \
+- "else " \
+- "run nand_boot; " \
+- "fi; " \
++ "mw.l 0x44e10650 0x05 ; " \
++ "if mmc rescan; then " \
++ "if run loadbootenv; then " \
++ "echo Loaded environment from ${bootenv};" \
++ "run importbootenv; " \
+ "fi; " \
+- "else " \
+- "run nand_boot; " \
+- "fi"
++ "if test -n $uenvcmd; then " \
++ "echo Running uenvcmd ...;" \
++ "run uenvcmd;" \
++ "fi;" \
++ "if run mmc_load_uimage; then " \
++ "run mmc_boot; " \
++ "fi; " \
++ "fi; " \
++ "run nand_boot; " \
+
+ #define CONFIG_DISPLAY_BOARDINFO
+ #define CONFIG_MISC_INIT_R
+--
+1.6.6.1
+
diff --git a/recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch b/recipes-bsp/u-boot/u-boot/0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch
--- /dev/null
@@ -0,0 +1,27 @@
+From 2f05cac97c5aba4d2dbd3e9ec6c53c8cbf27ee77 Mon Sep 17 00:00:00 2001
+From: Jason Kridner <jdk@ti.com>
+Date: Sat, 8 Oct 2011 16:57:08 -0400
+Subject: [PATCH 5/5] am335x_evm: remove redundant attempt to load uImage
+
+---
+ include/configs/am335x_evm.h | 4 +---
+ 1 files changed, 1 insertions(+), 3 deletions(-)
+
+diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
+index e157fd7..cb69176 100755
+--- a/include/configs/am335x_evm.h
++++ b/include/configs/am335x_evm.h
+@@ -175,9 +175,7 @@
+ "echo Running uenvcmd ...;" \
+ "run uenvcmd;" \
+ "fi;" \
+- "if run mmc_load_uimage; then " \
+- "run mmc_boot; " \
+- "fi; " \
++ "run mmc_boot; " \
+ "fi; " \
+ "run nand_boot; " \
+
+--
+1.6.6.1
+
index 9aebb1bcc8341617a443fa5419473a73ab20cb3e..5607bd6775b2f5c4b013dacba5ad44b74a95ebd8 100644 (file)
COMPATIBLE_MACHINE = "beaglebone"
DEFAULT_PREFERENCE_beaglebone = "99"
PV = "2011.09+git"
-PR = "r2"
+PR = "r3"
# SPL build
UBOOT_BINARY = "u-boot.img"
SRC_URI = "git://github.com/joelagnel/u-boot.git;protocol=git;branch=bone-bringup \
file://0001-am335x-evm-hack-in-ethernet-rmii-clock.patch \
+ file://0002-am335x_evm-reduced-bootdelay-to-0.patch \
+ file://0003-am335x_evm-boot-kernel-from-ext2-filesystem.patch \
+ file://0004-am335x_evm-read-uEnv.txt-instead-of-boot.scr.patch \
+ file://0005-am335x_evm-remove-redundant-attempt-to-load-uImage.patch \
"
SRCREV = "d643e691ab2055ef64f73dd70300a73e0443d1ef"