]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
u-boot: add missing patch for am37x-evm
authorChase Maupin <chasemaupin03@gmail.com>
Wed, 20 Jul 2011 15:47:56 +0000 (10:47 -0500)
committerKoen Kooi <koen@dominion.thruhere.net>
Wed, 20 Jul 2011 16:00:21 +0000 (18:00 +0200)
* am37x-evm machine in u-boot_git was missing a patch from
  the repository.

Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-bsp/u-boot/u-boot/0001-omap3evm-Change-default-console-serial-port-from.patch [new file with mode: 0644]
recipes-bsp/u-boot/u-boot_git.bb

diff --git a/recipes-bsp/u-boot/u-boot/0001-omap3evm-Change-default-console-serial-port-from.patch b/recipes-bsp/u-boot/u-boot/0001-omap3evm-Change-default-console-serial-port-from.patch
new file mode 100644 (file)
index 0000000..d171b78
--- /dev/null
@@ -0,0 +1,30 @@
+From 6b23ecf49d1c2ee5227ff57101919af46ecd7396 Mon Sep 17 00:00:00 2001
+From: Roger Monk <r-monk@ti.com>
+Date: Fri, 9 Jul 2010 08:37:04 +0100
+Subject: [PATCH] omap3evm:  Change default 'console' serial port from ttyS2 to ttyS0
+
+   * Update default kernel console env variable ($(console))
+     to use ttyS0 (instead of ttyS2) to match the serial port
+      used by x-loader and u-boot
+
+Signed-off-by: Roger Monk <r-monk@ti.com>
+---
+ include/configs/omap3_evm.h |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/include/configs/omap3_evm.h b/include/configs/omap3_evm.h
+index 73a5c98..d01d733 100644
+--- a/include/configs/omap3_evm.h
++++ b/include/configs/omap3_evm.h
+@@ -203,7 +203,7 @@
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+       "loadaddr=0x82000000\0" \
+       "usbtty=cdc_acm\0" \
+-      "console=ttyS2,115200n8\0" \
++      "console=ttyS0,115200n8\0" \
+       "mmcargs=setenv bootargs console=${console} " \
+               "root=/dev/mmcblk0p2 rw " \
+               "rootfstype=ext3 rootwait\0" \
+-- 
+1.6.0.4
+
index 8dac39116f8fccf2b9b528625ecad2e4bb5690ec..1f252fdecfc7bece596feb47fe0534a90297aeff 100644 (file)
@@ -1,5 +1,5 @@
 require u-boot.inc
-PR ="r66"
+PR ="r67"
 
 DEFAULT_PREFERENCE_ti814x = "-1"
 DEFAULT_PREFERENCE_ti816x = "-1"