summary | shortlog | log | commit | commitdiff | tree
raw | patch | inline | side by side (parent: 9338a26)
raw | patch | inline | side by side (parent: 9338a26)
author | Koen Kooi <koen@dominion.thruhere.net> | |
Fri, 6 Jan 2012 10:21:09 +0000 (11:21 +0100) | ||
committer | Koen Kooi <koen@dominion.thruhere.net> | |
Fri, 6 Jan 2012 10:22:49 +0000 (11:22 +0100) |
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.1/0031-am335x-evm-add-pdata-for-all-cape-EEPROM-permutation.patch b/recipes-kernel/linux/linux-ti33x-psp-3.1/0031-am335x-evm-add-pdata-for-all-cape-EEPROM-permutation.patch
--- /dev/null
@@ -0,0 +1,63 @@
+From 9365085cbe7061760f8ca4916b88b3c9c625f265 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Tue, 27 Dec 2011 20:17:36 +0100
+Subject: [PATCH 31/34] am335x-evm: add pdata for all cape EEPROM permutations
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ arch/arm/mach-omap2/board-am335xevm.c | 35 +++++++++++++++++++++++++++++---
+ 1 files changed, 31 insertions(+), 4 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c
+index 8e1521c..116089f 100644
+--- a/arch/arm/mach-omap2/board-am335xevm.c
++++ b/arch/arm/mach-omap2/board-am335xevm.c
+@@ -1148,14 +1148,41 @@ static struct i2c_board_info beaglebone_i2c_boardinfo2[] = {
+ },
+ };
+
++static struct at24_platform_data cape_eeprom_info = {
++ .byte_len = (256*1024) / 8,
++ .page_size = 64,
++ .flags = AT24_FLAG_ADDR16,
++ .context = (void *)NULL,
++};
++
++static struct i2c_board_info __initdata cape_i2c_boardinfo[] = {
++ {
++ I2C_BOARD_INFO("24c256", 0x54),
++ .platform_data = &cape_eeprom_info,
++ },
++ {
++ I2C_BOARD_INFO("24c256", 0x55),
++ .platform_data = &cape_eeprom_info,
++ },
++ {
++ I2C_BOARD_INFO("24c256", 0x56),
++ .platform_data = &cape_eeprom_info,
++ },
++ {
++ I2C_BOARD_INFO("24c256", 0x57),
++ .platform_data = &cape_eeprom_info,
++ },
++};
++
+ static void i2c2_init(int evm_id, int profile)
+ {
+- setup_pin_mux(i2c2_pin_mux);
+- omap_register_i2c_bus(3, 100, beaglebone_i2c_boardinfo2,
+- ARRAY_SIZE(beaglebone_i2c_boardinfo2));
+- return;
++ setup_pin_mux(i2c2_pin_mux);
++ omap_register_i2c_bus(3, 100, cape_i2c_boardinfo,
++ ARRAY_SIZE(cape_i2c_boardinfo));
++ return;
+ }
+
++
+ /* Setup McASP 1 */
+ static void mcasp1_init(int evm_id, int profile)
+ {
+--
+1.7.7.4
+
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.1.bb b/recipes-kernel/linux/linux-ti33x-psp_3.1.bb
index f7ec2f8018e7f03937b5677339189b5d19b7c2f3..c48435bf309a76ef4932c5f8f69bb91a6ade4a9f 100644 (file)
BRANCH = "v3.1-meta-ti-r1r+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d"
SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d"
-MACHINE_KERNEL_PR_append = "g+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "h+gitr${SRCREV}"
COMPATIBLE_MACHINE = "(ti33x)"
file://adc/0009-meta-ti-Remove-debug-messages-for-meta-ti.patch \
file://adc/0010-tscadc-switch-to-polling-instead-of-interrupts.patch \
file://st7735fb/0001-st7735fb-WIP-framebuffer-driver-supporting-Adafruit-.patch \
+ file://0031-am335x-evm-add-pdata-for-all-cape-EEPROM-permutation.patch \
"
SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}"