]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-ti33x-psp 3.1: add dto patch to fix problems with various sd cards
authorKoen Kooi <koen@dominion.thruhere.net>
Thu, 26 Jan 2012 17:38:04 +0000 (18:38 +0100)
committerKoen Kooi <koen@dominion.thruhere.net>
Fri, 27 Jan 2012 08:05:03 +0000 (09:05 +0100)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-kernel/linux/linux-ti33x-psp-3.1/0038-omap_hsmmc-Set-dto-to-max-value-of-14-to-avoid-SD-Ca.patch [new file with mode: 0644]
recipes-kernel/linux/linux-ti33x-psp_3.1.bb

diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.1/0038-omap_hsmmc-Set-dto-to-max-value-of-14-to-avoid-SD-Ca.patch b/recipes-kernel/linux/linux-ti33x-psp-3.1/0038-omap_hsmmc-Set-dto-to-max-value-of-14-to-avoid-SD-Ca.patch
new file mode 100644 (file)
index 0000000..4fe037e
--- /dev/null
@@ -0,0 +1,34 @@
+From d12058d27dddf60b36f5b2142ee999e55bddfff6 Mon Sep 17 00:00:00 2001
+From: Steve Sakoman <steve@sakoman.com>
+Date: Mon, 18 Jul 2011 23:13:41 -0500
+Subject: [PATCH 38/38] omap_hsmmc: Set dto to max value of 14 to avoid SD
+ Card timeouts
+
+This fixes MMC errors due to timeouts on certain SD Cards following suggestions
+to set dto to 14 by Jason Kridner and Steven Kipisz
+
+Details of the issue:
+http://talk.maemo.org/showthread.php?p=1000707#post1000707
+
+This fix was originally proposed by Sukumar Ghoral of TI.
+---
+ drivers/mmc/host/omap_hsmmc.c |    3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/drivers/mmc/host/omap_hsmmc.c b/drivers/mmc/host/omap_hsmmc.c
+index 35505bd..0be77ec 100644
+--- a/drivers/mmc/host/omap_hsmmc.c
++++ b/drivers/mmc/host/omap_hsmmc.c
+@@ -1574,6 +1574,9 @@ static void set_data_timeout(struct omap_hsmmc_host *host,
+                       dto = 14;
+       }
++      /* Set dto to max value of 14 to avoid SD Card timeouts */
++      dto = 14;
++
+       reg &= ~DTO_MASK;
+       reg |= dto << DTO_SHIFT;
+       OMAP_HSMMC_WRITE(host->base, SYSCTL, reg);
+-- 
+1.7.7.5
+
index 84e5c3ba0cad7b1c57de60fce7bcb36b86fdc9de..591731c87541d468eb37ddb87906955026d687bf 100644 (file)
@@ -11,7 +11,7 @@ MULTI_CONFIG_BASE_SUFFIX = ""
 
 BRANCH = "v3.1-meta-ti-r1r+gitr1d84d8853fa30cf3db2571a5aec572accca4e29d"
 SRCREV = "1d84d8853fa30cf3db2571a5aec572accca4e29d"
-MACHINE_KERNEL_PR_append = "k+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "l+gitr${SRCREV}"
 
 COMPATIBLE_MACHINE = "(ti33x)"
 
@@ -62,6 +62,7 @@ PATCHES_OVER_PSP = " \
        file://0035-beaglebone-add-structs-for-DVI-cape-LEDs.patch\
        file://0036-beaglebone-update-LCD-cape-partnumber.patch \
     file://0037-beaglebone-compare-complete-partnumber-not-the-first.patch \
+       file://0038-omap_hsmmc-Set-dto-to-max-value-of-14-to-avoid-SD-Ca.patch \
        "
 
 SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}"