]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
beaglebone-capes: add support for 4.3" LCD cape
authorKoen Kooi <koen@dominion.thruhere.net>
Thu, 7 Jun 2012 15:40:43 +0000 (17:40 +0200)
committerDenys Dmytriyenko <denys@ti.com>
Mon, 11 Jun 2012 20:59:07 +0000 (16:59 -0400)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-ti/beagleboard/beaglebone-capes.bb
recipes-ti/beagleboard/beaglebone-capes/cape-stop.sh
recipes-ti/beagleboard/beaglebone-capes/cape.sh

index f12892476a6fecb87f46b9b50ea682c276af3d65..2a9f1fb2fded9f92278904256d9f03e511a466b0 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Userspace setup for beaglebone capes"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
 
-PR = "r1"
+PR = "r2"
 
 inherit allarch
 
index a08498d70ffc7b70047414adce49392b546d506a..49500176a0a8489381a50ac4d674b55a656f1e1c 100755 (executable)
@@ -5,6 +5,9 @@ for eeprom in /sys/bus/i2c/devices/3-005*/eeprom ; do
                "BB-BONE-LCD3-01.")
                                echo "Turning off backlight for LCD3 cape"
                                i2cset -f -y 1 0x24 0x07 0x00;;
+               "BB-BONE-LCD4-01.")
+                               echo "Turning off backlight for LCD3 cape"
+                               i2cset -f -y 1 0x24 0x07 0x00;;
                *)
                                echo "unknown cape: $PARTNUMBER";;
        esac
index 69accfff08a8600ff3a592bf700dbaf289ab1f39..61240a5fb7acadfa5da9f2edaa2ac8de99dcf205 100755 (executable)
@@ -6,6 +6,10 @@ for eeprom in /sys/bus/i2c/devices/3-005*/eeprom ; do
                                echo "Turning on backlight for LCD3 cape"
                                i2cset -f -y 1 0x24 0x07 0x09
                                i2cset -f -y 1 0x24 0x08 0x60;;
+               "BB-BONE-LCD4-01.")
+                               echo "Turning on backlight for LCD4 cape"
+                               i2cset -f -y 1 0x24 0x07 0x09
+                               i2cset -f -y 1 0x24 0x08 0x60;;
                *)
                                echo "unknown cape: $PARTNUMBER";;
        esac