]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-ti-staging: mark dependencies am335x specific
authorChase Maupin <Chase.Maupin@ti.com>
Mon, 11 Mar 2013 20:03:33 +0000 (15:03 -0500)
committerDenys Dmytriyenko <denys@ti.com>
Mon, 11 Mar 2013 21:17:31 +0000 (17:17 -0400)
* The DEPENDS on am33x-cm3 and the installation of the cm3
  firmware is specific to ti33x SOC_FAMILY devices.  Mark those
  pieces as specific so that other devices to not depend on
  am335x cm3 firmware.

Signed-off-by: Chase Maupin <Chase.Maupin@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-kernel/linux/linux-ti-staging_git.bb

index 2581409916ae31b318856f6ba8a2605018574516..5f4a05ddd21df607887c6caf6b299900ab27a265 100644 (file)
@@ -9,7 +9,8 @@ require recipes-kernel/linux/linux-dtb.inc
 require recipes-kernel/linux/setup-defconfig.inc
 
 # Stage the power management firmware before building the kernel
-DEPENDS += "am33x-cm3"
+# for ti33x SOC_FAMILY devices
+DEPENDS_ti33x += "am33x-cm3"
 
 KERNEL_DEVICETREE_am335x-evm = "arch/arm/boot/dts/am335x-evm.dts"
 KERNEL_DEVICETREE_beaglebone = "arch/arm/boot/dts/am335x-bone.dts"
@@ -30,8 +31,8 @@ SRC_URI = "git://gitorious.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=g
            file://defconfig \
           "
 
-# Copy the am33x-cm3 firmware if it is available
-do_compile_prepend() {
+# Copy the am33x-cm3 firmware if it is available for ti33x SOC_FAMILY devices
+do_compile_prepend_ti33x() {
     if [ -e "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" ]
     then
         cp "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" "${S}/firmware"