]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-ti33x-psp 3.2: demote cpsw PHY message to INFO
authorKoen Kooi <koen@dominion.thruhere.net>
Thu, 17 May 2012 10:07:06 +0000 (12:07 +0200)
committerDenys Dmytriyenko <denys@ti.com>
Mon, 21 May 2012 21:12:27 +0000 (17:12 -0400)
This keeps them from appearing on the screen during quiet boots. They are still
being reported, so no info is lost.

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch [new file with mode: 0644]
recipes-kernel/linux/linux-ti33x-psp_3.2.bb

diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch
new file mode 100644 (file)
index 0000000..2aed646
--- /dev/null
@@ -0,0 +1,51 @@
+From 04924dfd0335b8adca0e7783112827df30e70a5f Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Thu, 17 May 2012 10:59:18 +0200
+Subject: [PATCH] cpsw,phy_device: demote PHY message to INFO
+
+This keeps them from appearing on the screen when booting with 'quiet'
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ drivers/net/ethernet/ti/cpsw.c |    2 +-
+ drivers/net/phy/phy_device.c   |    4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/drivers/net/ethernet/ti/cpsw.c b/drivers/net/ethernet/ti/cpsw.c
+index 86fe57d..d10996d 100644
+--- a/drivers/net/ethernet/ti/cpsw.c
++++ b/drivers/net/ethernet/ti/cpsw.c
+@@ -638,7 +638,7 @@ static void cpsw_slave_open(struct cpsw_slave *slave, struct cpsw_priv *priv)
+                   slave->data->phy_id, slave->slave_num);
+               slave->phy = NULL;
+       } else {
+-              printk(KERN_ERR"\nCPSW phy found : id is : 0x%x\n",
++              printk(KERN_INFO"\nCPSW phy found : id is : 0x%x\n",
+                       slave->phy->phy_id);
+               cpsw_set_phy_config(priv, slave->phy);
+               phy_start(slave->phy);
+diff --git a/drivers/net/phy/phy_device.c b/drivers/net/phy/phy_device.c
+index 83a5a5a..8b84789 100644
+--- a/drivers/net/phy/phy_device.c
++++ b/drivers/net/phy/phy_device.c
+@@ -380,7 +380,7 @@ struct phy_device * phy_connect(struct net_device *dev, const char *bus_id,
+        * PHY with the requested name */
+       d = bus_find_device_by_name(&mdio_bus_type, NULL, bus_id);
+       if (!d) {
+-              pr_err("PHY %s not found\n", bus_id);
++              pr_info("PHY %s not found\n", bus_id);
+               return ERR_PTR(-ENODEV);
+       }
+       phydev = to_phy_device(d);
+@@ -503,7 +503,7 @@ struct phy_device *phy_attach(struct net_device *dev,
+        * PHY with the requested name */
+       d = bus_find_device_by_name(bus, NULL, bus_id);
+       if (!d) {
+-              pr_err("PHY %s not found\n", bus_id);
++              pr_info("PHY %s not found\n", bus_id);
+               return ERR_PTR(-ENODEV);
+       }
+       phydev = to_phy_device(d);
+-- 
+1.7.7.6
+
index bb26c70f9e3d794fb5174073506282ac19534716..97c1cd03a4c2f5c67e377282ef26d7959f2a3010 100644 (file)
@@ -12,7 +12,7 @@ MULTI_CONFIG_BASE_SUFFIX = ""
 
 BRANCH = "v3.2-staging"
 SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01"
 
 BRANCH = "v3.2-staging"
 SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01"
-MACHINE_KERNEL_PR_append = "j+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "l+gitr${SRCREV}"
 
 COMPATIBLE_MACHINE = "(ti33x)"
 
 
 COMPATIBLE_MACHINE = "(ti33x)"
 
@@ -969,4 +969,5 @@ PATCHES_OVER_PSP = " \
        file://beaglebone/0040-beaglebone-export-SPI2-as-spidev-when-no-capes-are-u.patch \
     file://beaglebone/0043-st7735fb-Working-WIP-changes-to-make-DMA-safe-and-ad.patch \
        file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \
        file://beaglebone/0040-beaglebone-export-SPI2-as-spidev-when-no-capes-are-u.patch \
     file://beaglebone/0043-st7735fb-Working-WIP-changes-to-make-DMA-safe-and-ad.patch \
        file://beaglebone/0001-arm-boot-compressed-default-asm-arch-to-armv7-a.patch \
+       file://beaglebone/0045-cpws-phy_device-demote-PHY-message-to-INFO.patch \
 "
 "