]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-omapl138: fix alignment issue of 2.6.37 kernel with gcc-4.7
authorDenys Dmytriyenko <denys@ti.com>
Tue, 26 Feb 2013 03:48:33 +0000 (22:48 -0500)
committerDenys Dmytriyenko <denys@ti.com>
Mon, 18 Mar 2013 18:28:13 +0000 (14:28 -0400)
Patch by Steve Sakoman

Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-kernel/linux/linux-omapl138-psp_2.6.37.bb

index 9618d422dd501819ac8c4d9c80253867a9f33b86..0b6c50db3e3f8375da3491a376518e267267316a 100644 (file)
@@ -6,7 +6,7 @@ KERNEL_IMAGETYPE = "uImage"
 require multi-kernel.inc
 require tipspkernel.inc
 
-MACHINE_KERNEL_PR_append = "a"
+MACHINE_KERNEL_PR_append = "b"
 
 S = "${WORKDIR}/git"
 
@@ -34,3 +34,8 @@ PATCHES_OVER_PSP = " \
 
 # Updated PIO mode for MUSB help description
 PATCHES_OVER_PSP += "file://0001-musb-update-PIO-mode-help-information-in-Kconfig.patch"
+
+# Fix alignment issue with gcc-4.7
+PATCHES_OVER_PSP += " \
+    file://0001-arm-fix-builds-with-gcc-4.7.patch \
+"