]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
am33x-cm3: Split init script into its own package
authorFranklin S. Cooper Jr <fcooper@ti.com>
Tue, 7 May 2013 04:26:03 +0000 (23:26 -0500)
committerDenys Dmytriyenko <denys@ti.com>
Tue, 7 May 2013 15:43:05 +0000 (11:43 -0400)
* 3.8+ kernels use an init script to load the cm3 firmware.
* 3.2 kernel require the cm3 firmware during compile time therefore no init
  script is needed.
* Separate the init script from the main package and place it in its own
  package.

Signed-off-by: Denys Dmytriyenko <denys@ti.com>
recipes-bsp/ti/am33x-cm3_git.bb
recipes-kernel/linux/linux-ti-staging_3.8.bb

index 4829b78c86b892401e799bcf9b9e90395c5c2af7..3549fcdba98e9980f55cb383ec07aa5e8cff5760 100644 (file)
@@ -4,7 +4,7 @@ LICENSE = "TI-BSD"
 LIC_FILES_CHKSUM = "file://License.txt;md5=858099c817e47ea63559fc6b67ae8d91"
 
 PV = "04.06.00.10"
-PR = "r2"
+PR = "r3"
 
 # SRCREV corresponds to tag "AM335xPSP_04.06.00.10-rc1"
 SRCREV = "27ca4643e422245a95723de1df0247a00eada45b"
@@ -15,6 +15,10 @@ INITSCRIPT_PARAMS = "defaults 96"
 
 inherit update-rc.d
 
+UPDATERCPN = "${PN}-initscript"
+
+RDEPENDS_${PN}-initscript = "am33x-cm3"
+
 SRC_URI = "git://arago-project.org/git/projects/am33x-cm3.git;protocol=git;branch=${BRANCH} \
            file://init-am33x-cm3 \
           "
@@ -34,5 +38,8 @@ do_install() {
        install -m 0755 ${WORKDIR}/init-am33x-cm3 ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
 }
 
+PACKAGES =+ "${PN}-initscript"
+
 FILES_${PN} += "${base_libdir}/firmware"
 
+FILES_${PN}-initscript = "${sysconfdir}/*"
index 6e64fc5b00a2ab3554c2a44f58502f643ba1cf5a..4b93932ef112c3f9a15668003be29a79aad3aeb0 100644 (file)
@@ -11,7 +11,7 @@ require recipes-kernel/linux/setup-defconfig.inc
 
 # Add a run-time dependency for the PM firmware to be installed
 # on the target file system.
-RDEPENDS_kernel-base_ti33x += "am33x-cm3"
+RDEPENDS_kernel-base_ti33x += "am33x-cm3 am33x-cm3-initscript"
 
 # Default is to package all dts files for ti33x devices unless building
 # for the specific beaglebone machine.
@@ -30,7 +30,7 @@ SRCREV = "23e7f725a6af4ca44660c06bc3569f6ce705d1d0"
 PV = "3.8.8"
 
 # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
-MACHINE_KERNEL_PR_append = "c+gitr${SRCPV}"
+MACHINE_KERNEL_PR_append = "d+gitr${SRCPV}"
 
 SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git;protocol=git;branch=${BRANCH} \
            file://defconfig \