]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/commitdiff
linux-omap 2.6.39: fix writing to the TWL RTC
authorKoen Kooi <koen@dominion.thruhere.net>
Wed, 15 Jun 2011 19:14:34 +0000 (21:14 +0200)
committerKoen Kooi <koen@dominion.thruhere.net>
Wed, 15 Jun 2011 19:14:34 +0000 (21:14 +0200)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
recipes-kernel/linux/linux-omap-2.6.39/beagle/0006-OMAP3-BEAGLE-fix-RTC.patch [new file with mode: 0644]
recipes-kernel/linux/linux-omap_2.6.39.bb

diff --git a/recipes-kernel/linux/linux-omap-2.6.39/beagle/0006-OMAP3-BEAGLE-fix-RTC.patch b/recipes-kernel/linux/linux-omap-2.6.39/beagle/0006-OMAP3-BEAGLE-fix-RTC.patch
new file mode 100644 (file)
index 0000000..a7066f0
--- /dev/null
@@ -0,0 +1,27 @@
+From 5eb1ce0f0a5c6e4e31225967ef61812191c01de4 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 15 Jun 2011 16:25:50 +0200
+Subject: [PATCH 6/6] OMAP3: BEAGLE: fix RTC
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ arch/arm/mach-omap2/board-omap3beagle.c |    3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/board-omap3beagle.c b/arch/arm/mach-omap2/board-omap3beagle.c
+index 221bfda..61564a4 100644
+--- a/arch/arm/mach-omap2/board-omap3beagle.c
++++ b/arch/arm/mach-omap2/board-omap3beagle.c
+@@ -941,6 +941,9 @@ static void __init omap3_beagle_init(void)
+       omap3_beagle_init_rev();
+       omap3_beagle_i2c_init();
++      /* Ensure msecure is mux'd to be able to set the RTC. */
++      omap_mux_init_signal("sys_drm_msecure", OMAP_PIN_OFF_OUTPUT_HIGH);
++
+       if (cpu_is_omap3630()) {
+               gpio_buttons[0].gpio = 4;
+       }
+-- 
+1.6.6.1
+
index 9cb7f96ec706c63e4a6df15e42ecefb7be3184f6..b44e8980b32e401a8f3a63a756db40e5969dd4d6 100644 (file)
@@ -7,7 +7,7 @@ COMPATIBLE_MACHINE = "(beagleboard)"
 
 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
 SRCREV_pn-${PN} = "v2.6.39"
-MACHINE_KERNEL_PR_append = "i"
+MACHINE_KERNEL_PR_append = "j"
 
 FILESPATHPKG_prepend = "linux-omap-2.6.39:"
 
@@ -53,6 +53,7 @@ SRC_URI_append = " \
            file://beagle/0003-OMAP3-beagle-add-MADC-support.patch \
            file://beagle/0004-OMAP3-beagle-add-regulators-for-camera-interface.patch \
            file://beagle/0005-OMAP3-beagle-HACK-add-in-1GHz-OPP.patch \
+           file://beagle/0006-OMAP3-BEAGLE-fix-RTC.patch \
            \
            file://camera/0001-Add-driver-for-Aptina-Micron-mt9p031-sensor.patch \
            file://camera/0002-v4l-Add-mt9v032-sensor-driver.patch \