summary | shortlog | log | commit | commitdiff | tree
raw | patch | inline | side by side (from parent 1: 6203cbc)
raw | patch | inline | side by side (from parent 1: 6203cbc)
author | Koen Kooi <koen@dominion.thruhere.net> | |
Thu, 16 Aug 2012 09:18:35 +0000 (11:18 +0200) | ||
committer | Denys Dmytriyenko <denys@ti.com> | |
Fri, 14 Sep 2012 05:51:07 +0000 (01:51 -0400) |
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0085-beaglebone-mux-camera-cape-orientation-pin-to-gpio.patch b/recipes-kernel/linux/linux-ti33x-psp-3.2/beaglebone/0085-beaglebone-mux-camera-cape-orientation-pin-to-gpio.patch
--- /dev/null
@@ -0,0 +1,35 @@
+From cfef44a953b640d592133ed553c1c4ba72953837 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Wed, 15 Aug 2012 14:33:37 +0200
+Subject: [PATCH] beaglebone: mux camera cape orientation pin to gpio
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ arch/arm/mach-omap2/board-am335xevm.c | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c
+index d30c5a2..78c4bf9 100644
+--- a/arch/arm/mach-omap2/board-am335xevm.c
++++ b/arch/arm/mach-omap2/board-am335xevm.c
+@@ -846,6 +846,7 @@ static struct pinmux_config gpmc_pin_mux[] = {
+ static struct pinmux_config camera_cape_pin_mux[] = {
+ {"spi0_d1.gpio0_4", OMAP_MUX_MODE7 | AM33XX_PIN_OUTPUT }, // QL CSSP and Camera Sensor Reset
+ {"spi0_cs0.gpio0_5", OMAP_MUX_MODE7 | AM33XX_PIN_OUTPUT_PULLUP }, // 1V8 and 2V8 Power Enable
++ {"gpmc_csn1.gpio0_30", OMAP_MUX_MODE7 | AM33XX_PIN_INPUT}, // Sensor orientation detect: low -> frontfacing, high -> backfacing
+ {NULL, 0},
+ };
+
+@@ -2065,8 +2066,8 @@ static void cssp_gpmc_init(void)
+ { NULL, GPMC_DEVICE_NOR },
+ };
+
+- setup_pin_mux(camera_cape_pin_mux);
+ setup_pin_mux(gpmc_pin_mux);
++ setup_pin_mux(camera_cape_pin_mux);
+
+ omap_init_gpmc(gpmc_device, sizeof(gpmc_device));
+ gpmc_cssp_init();
+--
+1.7.7.6
+
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.2.bb b/recipes-kernel/linux/linux-ti33x-psp_3.2.bb
index 77b16801e8ef37604988b00bbcddcaaf2eb8f7a4..5cbf46b73ff25fec06ebf12af37d9c5ef9ffd050 100644 (file)
BRANCH = "v3.2-staging"
SRCREV = "720e07b4c1f687b61b147b31c698cb6816d72f01"
-MACHINE_KERNEL_PR_append = "a+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "b+gitr${SRCREV}"
COMPATIBLE_MACHINE = "(ti33x)"
file://beaglebone/0082-beaglebone-add-rudimentary-support-for-eMMC-cape.patch \
file://beaglebone/0083-beaglebone-add-extra-partnumber-for-camera-cape.patch \
file://beaglebone/0084-beaglebone-cssp_camera-driver-cleanup.patch \
+ file://beaglebone/0085-beaglebone-mux-camera-cape-orientation-pin-to-gpio.patch \
"