linux 3.1: set COMPATIBLE_MACHINE to beagleboard for the time being to work around...