sdcard_image bbclass: make it work with older losetup versions among other things