util/demux: update use of deprecated API