]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/api/Makefile.am
Linux: Update autotools generated files
[ipc/ipcdev.git] / linux / src / api / Makefile.am
index 6f03c8ded5802056a0329cae4769225ae385727e..940261523d443a6512da930d5ff34feb30afdefc 100644 (file)
@@ -1,5 +1,5 @@
 ##
-##  Copyright (c) 2013, Texas Instruments Incorporated
+##  Copyright (c) 2013-2014, Texas Instruments Incorporated
 ##
 ##  Redistribution and use in source and binary forms, with or without
 ##  modification, are permitted provided that the following conditions
@@ -36,6 +36,10 @@ AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/hlos_common/include \
         -I$(top_srcdir)/packages -I$(KERNEL_INSTALL_DIR)/include/generated/uapi\
         -D_GNU_SOURCE -Wall @AM_CFLAGS@
 
+if DRA7XX
+AM_CFLAGS += -DGATEMP_SUPPORT
+endif
+
 ###############################################################################
 # THE LIBRARIES TO BUILD
 ###############################################################################
@@ -69,7 +73,22 @@ libtiipc_la_SOURCES =    \
                         NameServer.c \
                         Ipc.c
 
+if DRA7XX
+libtiipc_la_SOURCES +=  $(top_srcdir)/linux/include/IGateProvider.h \
+                        $(top_srcdir)/linux/include/GateHWSpinlock.h \
+                        $(top_srcdir)/linux/include/GateMutex.h \
+                        $(top_srcdir)/linux/include/GateMP_config.h \
+                        $(top_srcdir)/linux/include/_GateMP.h \
+                        $(top_srcdir)/packages/ti/ipc/GateMP.h \
+                        $(top_srcdir)/linux/src/api/gates/GateMP.c \
+                        $(top_srcdir)/linux/src/api/gates/GateMutex.c \
+                        $(top_srcdir)/linux/src/api/gates/GateHWSpinlock.c
+endif
+
 # Add version info to the shared library
 libtiipc_la_LDFLAGS = -version-info 1:0:0
-                                               
+
+pkgconfig_DATA          = libtiipc.pc
+pkgconfigdir            = $(libdir)/pkgconfig
+
 ###############################################################################