]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/api/Makefile.am
Added AF_RPMSG to products.mak to improve ease-of-use
[ipc/ipcdev.git] / linux / src / api / Makefile.am
index 940261523d443a6512da930d5ff34feb30afdefc..cd94065337c13228d9505eb9ecefea485a9be071 100644 (file)
@@ -1,5 +1,5 @@
 ##
-##  Copyright (c) 2013-2014, Texas Instruments Incorporated
+##  Copyright (c) 2013-2015 Texas Instruments Incorporated - http://www.ti.com
 ##
 ##  Redistribution and use in source and binary forms, with or without
 ##  modification, are permitted provided that the following conditions
 ##
 
 # additional include paths necessary to compile the library
-AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/hlos_common/include \
-        -I$(top_srcdir)/packages -I$(KERNEL_INSTALL_DIR)/include/generated/uapi\
-        -D_GNU_SOURCE -Wall @AM_CFLAGS@
+AM_CFLAGS = -I$(top_srcdir)/hlos_common/include -D_GNU_SOURCE -Wall
 
 if DRA7XX
 AM_CFLAGS += -DGATEMP_SUPPORT
 endif
 
+if KERNEL_INSTALL_DIR
+AM_CFLAGS += -I$(KERNEL_INSTALL_DIR)/include/generated/uapi
+endif
+
+AM_CFLAGS += -I$(top_srcdir)/linux/include -I$(top_srcdir)/packages @AM_CFLAGS@
+
 ###############################################################################
 # THE LIBRARIES TO BUILD
 ###############################################################################