]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/api/Makefile.am
6636: More Linux and BIOS 6636 support
[ipc/ipcdev.git] / linux / src / api / Makefile.am
index f9ad0f9c97a274ce5b52089fba42d5eaa698c603..e072f0a6e4cfab09e45cb67568c20711d98e0271 100644 (file)
@@ -32,8 +32,8 @@
 ##
 
 # additional include paths necessary to compile the library
-AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/packages \
-        -D_GNU_SOURCE -Wall @AM_CFLAGS@
+AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/hlos_common/include \
+        -I$(top_srcdir)/packages -D_GNU_SOURCE -Wall @AM_CFLAGS@
 
 ###############################################################################
 # THE LIBRARIES TO BUILD
@@ -43,29 +43,30 @@ AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/packages \
 lib_LTLIBRARIES = libtiipc.la
 
 # where to install the headers on the system
-libtiipc_ladir = $(includedir)
+libtiipc_ladir = $(includedir)/ti/ipc
 
 # the list of header files that belong to the library (to be installed later)
-libtiipc_la_HEADERS =    \
-                        $(top_srcdir)/linux/include/Std.h \
-                        $(top_srcdir)/linux/include/SysLink.h
+libtiipc_la_HEADERS = $(top_srcdir)/linux/include/ti/ipc/Std.h
 
 # the sources to add to the library and to add to the source distribution
 libtiipc_la_SOURCES =    \
                         $(libtiipc_la_HEADERS) \
                         $(top_srcdir)/linux/include/_MultiProc.h \
-                        $(top_srcdir)/linux/include/_MessageQ.h \
-                        $(top_srcdir)/linux/include/_NameServer.h \
+                        $(top_srcdir)/hlos_common/include/_MessageQ.h \
+                        $(top_srcdir)/hlos_common/include/_NameServer.h \
                         $(top_srcdir)/linux/include/ladclient.h \
                         $(top_srcdir)/linux/include/_lad.h \
                         $(top_srcdir)/linux/include/SocketFxns.h \
                         $(top_srcdir)/linux/include/net/rpmsg.h \
+                        $(top_srcdir)/packages/ti/ipc/Ipc.h \
                         $(top_srcdir)/packages/ti/ipc/NameServer.h \
                         $(top_srcdir)/packages/ti/ipc/MultiProc.h \
                         $(top_srcdir)/packages/ti/ipc/MessageQ.h \
+                        $(top_srcdir)/linux/include/ti/ipc/Std.h \
                         MessageQ.c \
+                        MultiProc.c \
                         NameServer.c \
-                        SysLink.c
+                        Ipc.c
 
 # Add version info to the shared library
 libtiipc_la_LDFLAGS = -version-info 1:0:0