]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - ipc/ipcdev.git/blobdiff - linux/src/daemon/Makefile.am
Makefile: Include GATE related sources for all platforms.
[ipc/ipcdev.git] / linux / src / daemon / Makefile.am
index 4634d64b8a73a2149e15b42efeda4e2c39b46322..ecb9b72a19d7ef7ab8f4a6d7f5e45c727dba7211 100644 (file)
@@ -1,5 +1,5 @@
 ##
-##  Copyright (c) 2013, Texas Instruments Incorporated
+##  Copyright (c) 2013-2015 Texas Instruments Incorporated - http://www.ti.com
 ##
 ##  Redistribution and use in source and binary forms, with or without
 ##  modification, are permitted provided that the following conditions
 ##
 
 # additional include paths necessary to compile the program
-AM_CFLAGS = -I$(top_srcdir)/linux/include -I$(top_srcdir)/hlos_common/include \
-        -I$(top_srcdir)/packages -I$(KERNEL_INSTALL_DIR)/include/generated/uapi\
-        -D_GNU_SOURCE -Wall @AM_CFLAGS@
+AM_CFLAGS = -I$(top_srcdir)/hlos_common/include -D_GNU_SOURCE -Wall -pthread \
+        -DKERNEL_INSTALL_DIR="$(KERNEL_INSTALL_DIR)"
+
+if DRA7XX
+AM_CFLAGS += -DGATEMP_SUPPORT
+endif
+
+if KERNEL_INSTALL_DIR
+AM_CFLAGS += -I$(KERNEL_INSTALL_DIR)/include/generated/uapi
+endif
+
+if AF_RPMSG
+AM_CFLAGS += -DAF_RPMSG=$(AF_RPMSG)
+endif
+
+AM_CFLAGS += -I$(top_srcdir)/linux/include -I$(top_srcdir)/packages @AM_CFLAGS@
 
 ###############################################################################
 # THE PROGRAMS TO BUILD
@@ -52,16 +65,28 @@ else
 if OMAPL138
   bin_PROGRAMS += lad_omapl138
 else
+if C66AK2E
+  bin_PROGRAMS += lad_66ak2e
+else
 if TCI6614
   bin_PROGRAMS += lad_tci6614
 else
-if TCI6638
-  bin_PROGRAMS += lad_tci6638
+if TCI6630
+  bin_PROGRAMS += lad_tci6630
 else
 if TCI6636
   bin_PROGRAMS += lad_tci6636
 else
-  bin_PROGRAMS += lad_omap54xx_smp lad_dra7xx lad_omapl138 lad_tci6614 lad_tci6636 lad_tci6638
+if TCI6638
+  bin_PROGRAMS += lad_tci6638
+else
+if C66AK2G
+  bin_PROGRAMS += lad_66ak2g
+else
+  bin_PROGRAMS += lad_omap54xx_smp lad_dra7xx lad_omapl138 lad_66ak2e lad_tci6614 lad_tci6630 lad_tci6636 lad_tci6638 lad_66ak2g
+endif
+endif
+endif
 endif
 endif
 endif
@@ -71,13 +96,17 @@ endif
 
 common_sources = \
                 lad.c \
+                Ipc_daemon.c \
+                cfg/IpcCfg.c \
                 MessageQ_daemon.c \
+                cfg/MessageQCfg.c \
                 MultiProc_daemon.c \
                 NameServer_daemon.c \
                 $(top_srcdir)/linux/include/ti/ipc/Std.h \
                 $(top_srcdir)/hlos_common/include/_NameServerRemoteRpmsg.h \
                 $(top_srcdir)/hlos_common/include/_MessageQ.h \
                 $(top_srcdir)/hlos_common/include/_NameServer.h \
+                $(top_srcdir)/linux/include/_Ipc.h \
                 $(top_srcdir)/linux/include/_MultiProc.h \
                 $(top_srcdir)/linux/include/_lad.h \
                 $(top_srcdir)/linux/include/SocketFxns.h \
@@ -87,16 +116,33 @@ common_sources = \
                 $(top_srcdir)/packages/ti/ipc/NameServer.h \
                 $(top_srcdir)/packages/ti/ipc/MultiProc.h
 
+common_sources += \
+                GateMP_daemon.c \
+               GateHWSpinlock.c \
+               GateHWSpinlock_daemon.c \
+               cfg/GateHWSpinlockCfg_dra7xx.c \
+               $(top_srcdir)/linux/src/api/gates/GateMutex.c \
+               $(top_srcdir)/linux/include/_GateMP.h \
+                $(top_srcdir)/linux/include/_GateMP_daemon.h \
+                $(top_srcdir)/linux/include/IGateProvider.h \
+                $(top_srcdir)/linux/include/GateHWSpinlock.h \
+                $(top_srcdir)/linux/include/GateMutex.h \
+                $(top_srcdir)/linux/include/GateMP_config.h \
+                $(top_srcdir)/packages/ti/ipc/GateMP.h
+
 # list of sources for the 'lad' binary and to add to the source distribution
 #
 # NOTE:  6636_SOURCES using 6638.c is not a typo!  6636 has the same
 # MultiProc config as 6638, so we reuse that source file.
-lad_omap54xx_smp_SOURCES = $(common_sources) MultiProcCfg_omap54xx_smp.c
-lad_dra7xx_SOURCES = $(common_sources) MultiProcCfg_dra7xx.c
-lad_omapl138_SOURCES = $(common_sources) MultiProcCfg_omapl138.c
-lad_tci6614_SOURCES = $(common_sources) MultiProcCfg_tci6614.c
-lad_tci6636_SOURCES = $(common_sources) MultiProcCfg_tci6638.c
-lad_tci6638_SOURCES = $(common_sources) MultiProcCfg_tci6638.c
+lad_omap54xx_smp_SOURCES = $(common_sources) cfg/MultiProcCfg_omap54xx_smp.c
+lad_dra7xx_SOURCES = $(common_sources) cfg/MultiProcCfg_dra7xx.c
+lad_omapl138_SOURCES = $(common_sources) cfg/MultiProcCfg_omapl138.c
+lad_66ak2e_SOURCES = $(common_sources) cfg/MultiProcCfg_66ak2e.c
+lad_tci6614_SOURCES = $(common_sources) cfg/MultiProcCfg_tci6614.c
+lad_tci6630_SOURCES = $(common_sources) cfg/MultiProcCfg_tci6630.c
+lad_tci6636_SOURCES = $(common_sources) cfg/MultiProcCfg_tci6638.c
+lad_tci6638_SOURCES = $(common_sources) cfg/MultiProcCfg_tci6638.c
+lad_66ak2g_SOURCES = $(common_sources) cfg/MultiProcCfg_66ak2g.c
 
 common_libraries = -lpthread \
                 $(top_builddir)/linux/src/utils/libtiipcutils_lad.la
@@ -108,11 +154,17 @@ lad_dra7xx_LDADD = $(common_libraries) \
                 $(AM_LDFLAGS)
 lad_omapl138_LDADD = $(common_libraries) \
                 $(AM_LDFLAGS)
+lad_66ak2e_LDADD = $(common_libraries) \
+                $(AM_LDFLAGS)
 lad_tci6614_LDADD = $(common_libraries) \
                 $(AM_LDFLAGS)
+lad_tci6630_LDADD = $(common_libraries) \
+                $(AM_LDFLAGS)
 lad_tci6636_LDADD = $(common_libraries) \
                 $(AM_LDFLAGS)
 lad_tci6638_LDADD = $(common_libraries) \
                 $(AM_LDFLAGS)
+lad_66ak2g_LDADD = $(common_libraries) \
+                $(AM_LDFLAGS)
 
 ###############################################################################